I have Ubuntu 13.10 64-bit and chrome 64-bit.

I can start chrome from the command line with google-chrome-stable and lock it to the launcher, but when I try to launch chrome from the launcher nothing happens.

What do I have to do to make chrome working with the launcher?

  • I copied the file /usr/share/applications/google-chrome.desktop to my Desktop and I can launch it from there. It still doesn't work from the Launcher, however. – Dean Schulze Feb 10 '14 at 23:30
  • 1
    I have this issue too. Hope someone can figure this out. – Eugene Bulkin Feb 11 '14 at 6:29
  • Still have this issue with Ubuntu 14.0* and Chrome 38 – Domi Oct 20 '14 at 17:38

You probably have an old version, or a version with an error, of the .desktop file in ~/.local/share/applications. The "reading priority" of the launcher is:

  1. the local directory for desktop files in in ~/.local/share/applications,
  2. the global directory for desktop files in /usr/share/applications.

That means that if you start the application from the "right" (global) .desktop file, the launcher will check for a local version of the .desktop file on the next occasion and use the contents of that file.

You will have to remove the local .desktop file, log out and in, and lock the icon to the launcher again.

  • 2
    That solved it! Great! When using Super and searching for chrome, it finds two. One is called "Chrome - Google Chrome" and one is just called "Google Chrome". The former one does not work, and its what was linked against the launcher for some reason. – Domi Oct 20 '14 at 17:43

In my case, the problem was that the local launcher definition (~/.local/share/applications/google-chrome-stable.desktop) was pointing to the wrong path for the chrome executable. Using whereis google-chrome-stable I replaced to the right path, then started google-chrome-stable & from terminal, locked to the launcher, voila.

Your Chrome window may be off screen. Try checking your workspace settings.

To see that the process is still there.

In the terminal type:

ps ax | grep -i chrome

In the terminal type:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

If the window still is not showing up, you may need to reboot the system so the changes apply.

  • 1
    Why would this be happening? Do you know? – Seth Mar 20 '14 at 20:03
  • 1
    Nope. The icon is blinking for a while, then stops blinking. Chrome has never started. – Domi Oct 20 '14 at 17:39

protected by Community Jan 29 '15 at 0:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.