I have tried various ways to get bumblebee running on a fresh Ubuntu 13.10 install with all the updates. However I seem to be having trouble getting it to work at all. I have followed the instructions here: https://wiki.ubuntu.com/Bumblebee#Installation. This has been immediately after installing restricted extras, vlc, chrome and allowing Ubuntu to update. Nothing else was changed. Any ideas appreceated.

Got an Acer Aspire V5-573G

Intel Core i5-4200U

NVIDIA GeForce GT 750M

Some problems I got fixed (like changing the BUSId to 01:00.0.

This is my /etc/bumblebee/bumblebee.conf

    # Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
# The secondary Xorg server DISPLAY number
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
# The name of the Bumbleblee server group name (GID name)
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
# Directory with a dummy config file to pass as a -configdir to secondary X

## Client options. Will take effect on the next optirun executed.
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path

## Section with nouveau driver specific options, only parsed if Driver=nouveau

Here is the xorg.conf.nvidia

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    BusID "PCI:01:00.0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"

This is my output if I try using optirun:

vytautas@vytautas-laptop:~$ optirun glxgears
[ 1861.794624] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 1861.794679] [ERROR]Aborting because fallback start is disabled.

And finally these are the last lines of my kernel.log

Feb  8 22:43:49 vytautas-laptop kernel: [  584.014406] bbswitch: version 0.8
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014414] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014421] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.RP05.PXSX
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014433] bbswitch: failed to evaluate \_SB_.PCI0.RP05.PXSX._DSM {0xF8,0xD8,0x86,0xA4,0xDA,0x0B,0x1B,0x47,0xA7,0x2B,0x60,0x42,0xA6,0xB5,0xBE,0xE0} 0x100 0x0 {0x00,0x00,0x00,0x00}: AE_NOT_FOUND
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014440] bbswitch: failed to evaluate \_SB_.PCI0.RP05.PXSX._DSM {0xA0,0xA0,0x95,0x9D,0x60,0x00,0x48,0x4D,0xB3,0x4D,0x7E,0x5F,0xEA,0x12,0x9F,0xD4} 0x102 0x0 {0x00,0x00,0x00,0x00}: AE_NOT_FOUND
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014447] ACPI Warning: \_SB_.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Feb  8 22:43:49 vytautas-laptop kernel: [  584.014488] bbswitch: No suitable _DSM call found.

Also, as a side note even though I made sure I got the drivers installed through the APT I get this:

vytautas@vytautas-laptop:~$ sudo nvidia-xconfig
sudo: nvidia-xconfig: command not found

Thank You


Updating from 12.04 to 14.04 solved some of my graphic problems.

Suddenly the Nvidia driver was working haven't tried Bumblebee yet.

But I think you need the Version 331 so have you tried this Tutorial: -> http://www.muktware.com/2013/12/install-nvidia-331-bumblebee-optimus-cards/18271

/usr/lib/nux/unity_support_test -p


OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce GT 750M/PCIe/SSE2
OpenGL version string:  4.4.0 NVIDIA 331.38

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

I am having an issue with Optimus on my Acer V5-473G.

I have scoured the internet since December 2013 and have not been able to get this to work. I have tried the ACPI hack, xorg edgers repo with no luck.

The Intel integrated graphics work well, but it would be nice to also have the ability to use the nVidia 740M that is in this laptop aswell.

  • Well, personally I think now we have to wait for the Ubuntu 14 release as I've heard it should have better support for Optimus out of the box with card switching. We'll see. – HellDuke Feb 24 '14 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.