This question already has an answer here:

I just installed Ubuntu 13.10 in legacy mode (secure boot disabled) next to a Windows 8.1 partition. Ubuntu works perfectly (in UEFI and in legacy modes) but I can't load Windows anymore - there is no Windows entry in the Grub boot choices.

When the secure boot is enabled, I can't load Ubuntu anymore ('No bootable devices').

I've tried to repair the system with Boot Repair, but nothing changed.

Any help appreciated !


(My machine is a Dell XPS13)

marked as duplicate by Luis Alvarado Mar 4 '14 at 17:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I suggest you use windows inside virtual box. – Dusan Milosevic Feb 8 '14 at 20:00
  • have you tried to update grub via cli? ie: sudo update grub – rob j loranger Feb 8 '14 at 20:31

If you have a Windows re-install disc you can use dism to re-write your Windows bootloader, however this will Disable your ability to boot Ubuntu and require you to re-install ubuntu.

In WINDOWS command prompt type:

"bcdboot C:\Windows /s E: /f UEFI" (C is your windows location, change accordingly. E is your UEFI partition, change accordingly as your drive letters may differ). To see what drive letters to use type "notepad" into the command prompt then "File/Open" to browse so you can see what letters are in use. If your UEFI parition isn't mounted which it likely won't be then you will need to do so by in command prompt typing "diskpart", "list disk", "select disk 0" (or whatever disk it's on), "select partition 0" (or whatever partition it is), "assign letter=q" (or whatever letter you want to use that is currently free).

If you don't have a windows re-install disc you can always download the Windows 8.1 - Enterprise X86-64 iso file. Registration is required.


  • Thank you ! In fact it appears that Ubuntu has overridden the Windows partition. I have to reinstall Windows ... – user246129 Feb 9 '14 at 19:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.