1

Does anyone know how to install PHP on Ubuntu with fastcgi enabled? I've installed my PHP from the following site: http://www.dev-metal.com/how-to-setup-latest-version-of-php-5-5-on-ubuntu-12-04-lts/

I've looked into installing fastcgi via (apt-get install libapache2-mod-fastcgi) and have come up with the following error:

The following packages have unmet dependencies:
libapache2-mod-fastcgi : Depends: apache2.2-common (>= 2.2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've hit the wall on this without any solutions, am running the latest Apache version 2.4, could use some help on this.

  • Have you tried askubuntu.com/questions/140246/… ? – user.dz Feb 8 '14 at 19:02
  • Thanks for the link, yes gave it a look and didn't see a solution for resolving a dependency that is an older version that what I have installed currently. – webdev Feb 8 '14 at 19:55
  • The developer who has ppa:ondrej/php5 which you have installed apache from, has another ppa:ondrej/apache2 which has built libapache2-mod-fastcgi But I'm not sure it will work or conflict with other apache as both have apache2.4. See launchpad.net/~ondrej/+archive/… – user.dz Feb 8 '14 at 22:14
  • Thanks for providing this link, am hesitant to try it after what happened last time! Working on a project and don't want uninstall apache2 just yet. – webdev Feb 8 '14 at 23:00
  • 1
    Fixed, installed the fastcgi mod and reinstalled apache2, it works now. Put up an answer, thanks for the help Sneetsher. – webdev Feb 9 '14 at 10:26
1

The developer who has ppa:ondrej/php5 which you have installed Apache2 from, has another ppa:ondrej/apache2 which has built libapache2-mod-fastcgi for apache2.4.

See https://launchpad.net/~ondrej/+archive/apache2?field.series_filter=precise

Both PPA's has apache2.4, You may download only libapache2-mod-fastcgi package to avoid Apache2 version racing if they are not the same.

But as of 2016 Feb, libapache2-mod-fastcgi in the ppa:ondrej/apache2 only supports trusty 14.04, vivid, 15.04, and wily 15.10. Seems there is no support for precise 12.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.