3

Gents,

I'm new on Linux and I tried to start .NET under Ubuntu when I start debugging a sample from MonoDevelop ASP.NET app it gives the following error:

Could not launch web server. The "XSP4" web server cannot be started.

From tty when running xsp4 it gives the following:

Missing method
System.Configuration.IConfigurationSectionHandler::Create(object,object,XmlNode)
in assembly /usr/lib/mono/4.0/System.dll, referenced in assembly
/usr/lib/mono/4.0/System.Configuration.dll Exception caught during
reading the configuration file: System.MissingMethodException: Method
not found: 'System.Configuration.IConfigurationSectionHandler.Create'.
at
System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection
(System.String configKey) [0x00000] in <filename unknown>:0    at
System.Configuration.ConfigurationManager.GetSection (System.String
sectionName) [0x00000] in <filename unknown>:0    at
System.Configuration.ConfigurationManager.get_AppSettings () [0x00000]
in <filename unknown>:0    at
Mono.WebServer.XSP.Server.get_AppSettings () [0x00000] in <filename
unknown>:0    at Mono.WebServer.XSP.Server+ApplicationSettings..ctor
() [0x00000] in <filename unknown>:0  xsp4 Listening on address:
0.0.0.0 Root directory: /home/tarik/Documents/Courses/Mono/ASP.NET/FirstApp Error:
System.TypeInitializationException: An exception was thrown by the
type initializer for System.Net.Sockets.Socket --->
System.InvalidCastException: Cannot cast from source type to
destination type.   at System.Net.Sockets.Socket.CheckProtocolSupport
() [0x00000] in <filename unknown>:0    at
System.Net.Sockets.Socket..cctor () [0x00000] in <filename unknown>:0 
--- End of inner exception stack trace ---   at Mono.WebServer.XSPWebSource.CreateSocket () [0x00000] in <filename
unknown>:0    at Mono.WebServer.ApplicationServer.Start (Boolean
bgThread) [0x00000] in <filename unknown>:0    at
Mono.WebServer.ApplicationServer.Start (Boolean bgThread,
System.Exception initialException) [0x00000] in <filename unknown>:0  
at (wrapper remoting-invoke-with-check)
Mono.WebServer.ApplicationServer:Start (bool,System.Exception)   at
Mono.WebServer.XSP.Server.RealMain (System.String[] args, Boolean
root, IApplicationHost ext_apphost, Boolean quiet) [0x00000] in
<filename unknown>:0
1
0

Sometimes installing "mono-complete" will fix some errors. Try doing that if you don't have it installed already.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.