1

For some reason my audio output isn't being detected on boot-up or after issueing a pulseaudio -k command. Which means I can't set it as the default playback device.

The output for pactl list short sinks displays:

0   alsa_output.pci-0000_00_03.0.hdmi-stereo    module-alsa-card.c  s16le 2ch 44100Hz   IDLE
1   alsa_output.pci-0000_00_1b.0.analog-stereo  module-alsa-card.c  s16le 2ch 44100Hz   IDLE

However, when I go in to the sound settings, it lists 3 devices:

  • HDMI / DisplayPort 2 (This is what I need to use)
  • HDMI / DisplayPort
  • Analogue Output

Only once I've selected HDMI / DisplayPort 2 in the sound settings does the output of pactl list short sinks change to:

0   alsa_output.pci-0000_00_03.0.hdmi-stereo    module-alsa-card.c  s16le 2ch 44100Hz   IDLE
1   alsa_output.pci-0000_00_1b.0.analog-stereo  module-alsa-card.c  s16le 2ch 44100Hz   IDLE
2   alsa_output.pci-0000_00_03.0.hdmi-stereo-extra1 module-alsa-card.c  s16le 2ch 44100Hz   IDLE

At this point my ~/.config/pulse default-sink file now lists the -extra1 device as I'd like. However, after typing pulseaudio -k; everything (including the default-sink file) switches back to the analog output. Presumably because it can't find the listed output.

Is there a reason where pulseaudio can't see this third output by default? What's Sound Manager doing to detect it?

0

Here's a work-around for this:

Go to Sound Settings and change the sound to HDMI / DisplayPort 2. Then close the settings window and run the following command:

pacmd dump | grep set-card-profile

Copy the output of the command above and paste it at the bottom of the /etc/pulse/default.pa file (open it as root with a text editor, e.g.: "gksu /etc/pulse/default.pa")

  • Thanks, worked great. I also had to add in the set-default-sink to that default.pa file for it to pick it up correctly – Steve H Feb 11 '14 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.