0

I am trying to get the window-snap feature to work but cannot.

I started with Ubuntu 12.04 (installed on a VirtualBox with Windows 7 hosting). I can't get 3D acceleration to work on VirtualBox, so Unity 2d is running and doesn't have snap (since compiz isn't running, I assumed).

Following some googling, I found that you can set Unity 2d to use compiz. Tried that and my system didn't seem to like that either.

Next step, I tried switching to gnome shell, where I read that window snap is integrated. I installed gnome shell using:

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get install gnome-shell

Gnome shell works fine, but I still don't have window snap! Is there any way to get this simple feature to work?

2

Ok I solved it. Apparently gnome shell has the same problem that it needs 3d acceleration turned on, otherwise it defaults to a skinned-down called gnome panel, which does not have windows snap.

I will keep the question and answer in case someone find them useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.