I just realized I can't unrar .rar files on my Ubuntu machine!

What's the easiest way to accomplish this fundamental task? If possible I'd love something like 7Zip that I can just right Click, and extract and have the program worry about how to do it regardless if it's a .zip, a .rar or a .foo compressed file.

  • 1
    This should be possible. What happens when you try? – ændrük May 10 '11 at 14:37
  • 1
    @Andre: I recieved an error message saying I had to install new software. So I searched and it automatically installed a plugin, now it works fine. – Only Bolivian Here May 10 '11 at 14:52
  • 1
    From the command line, i always 'cheat' and install the 'unp' package - its a command line script that can auto detect and properly extract most common archives, if you have the proper archive programs installed. Just wanted to mention something people often overlook. – dr_willis May 10 '11 at 16:23

Ubuntu by default uses File Roller, which supports the following formats:

7-Zip Compressed File (.7z)
WinAce Compressed File (.ace)
ALZip Compressed File (.alz)
AIX Small Indexed Archive (.ar)
ARJ Compressed Archive (.arj)
Cabinet File (.cab)
UNIX CPIO Archive (.cpio)
Debian Linux Package (.deb) read-only
ISO-9660 CD Disc Image (.iso) read-only
Java Archive (.jar)
Java Enterprise archive (.ear)
Java Web Archive (.war)
LHA Archive (.lzh, .lha)
WinRAR Compressed Archive (.rar)
RAR Archived Comic Book (.cbr)
RPM Linux Package (.rpm) read-only
Stuffit Archives (.bin, .sit)
Tar Archives:
    uncompressed (.tar)
    compressed with:
        gzip (.tar.gz , .tgz)
        bzip (.tar.bz , .tbz)
        bzip2 (.tar.bz2 , .tbz2)
        compress (.tar.Z , .taz)
        lzip (.tar.lz , .tlz)
        lzop (.tar.lzo , .tzo)
        7zip (.tar.7z)
        xz (.tar.xz)
ZIP Archive (.zip)
ZIP Archived Comic Book (.cbz)
ZOO Compressed Archive File (.zoo)
Single files compressed with gzip, bzip, bzip2, compress, lzip, lzop, rzip, xz.

Keep in mind, that this is just graphical front-end, so you still need to install unrar for .rar support;

The unrar package is hosted on the Multiverse repository, so first you'll need to enable the Multiverse repository in Software & Updates;

Then you can install the package either by using Software Centre or by opening Terminal and running sudo apt-get install unrar.

  • 2
    I don't understand why this wouldn't "just work" in Ubuntu 18. – LondonRob Mar 5 at 11:44

First, run:

sudo apt-get update
sudo apt-get install unrar

You could read man unrar.

From terminal you can use next command:

unrar e -r /home/work/software/myfile.rar

Or, the following command if you want to preserve the directory structure too:

unrar x -r /home/work/software/myfile.rar
  • 13
    First you need to run sudo apt-get install unrar to install unrar. – Nicolas Raoul Nov 21 '14 at 2:41
  • If the install fails to find these packages, try apt-cache search unrar. On a raspberry pi, for example the package was named unrar-free so you'd have to install it with sudo apt-get install unrar-free – biscuit314 Sep 13 '17 at 22:37

Install unrar from the Software Center or by running the command

sudo apt install unrar
  • 1
    can't be found in software center in ubuntu 18 but the link worked like charm – n0krashy May 24 '18 at 22:31

If you like then you can also use p7zip-full package. You can install it as:

sudo apt-get install p7zip-full p7zip-rar

The main purpose of this package is to provide 7z and 7za file archivers with high compression ratio.

  • For this I get "Package p7zip-rar is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source" – Roy Truelove Jan 26 '17 at 19:52
  • @RoyTruelove , apt-cache search p7zip-rar , what is the output ? – rɑːdʒɑ Jan 27 '17 at 4:24
 sudo apt-get install unrar;

Reading package lists... Done Building dependency tree
Reading state information... Done Package unrar is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'unrar' has no installation candidate

I tried above all on Ubuntu DISTRIB_RELEASE=16.04 But not worked

The following command worked fine for me.

sudo apt-get install unrar-free

The half-GUI method:

sudo apt update
sudo apt install unrar

Then, in your favorite file manager (ex: nemo [my favorite], or nautilus [Ubuntu's default]), right-click the .rar file and go to Extract Here. Done!

enter image description here

protected by Community Jun 4 '13 at 6:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.