17

Re-enabling hibernation by adding a rule to policy kit added the option to hibernate to the desktop session as expected, but not for the login screen.

How can I enable hibernation right from the login screen on 14.04?

  • Which Display Manager are you using? – landroni Feb 23 '14 at 22:23
  • I'm using lightdm. – Dusan Milosevic Feb 23 '14 at 22:30
  • is the graphic card driver installed ? – EKanadily Feb 28 '14 at 0:39
  • Did you check #pm-hibernate working fine ? – bitsbuffer Feb 28 '14 at 6:07
  • 1
    Yes, as I said, hibernation works fine, but the hibernate is missing in login screen. – Dusan Milosevic Feb 28 '14 at 9:22
6

The address of the policy kit file changed in Ubuntu 14.04.

Follow the same steps as before, except replacing the file:

/var/lib/polkit-1/localauthority/10-local.d/hibernate.pkla

with this one:

/var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

Try this one

sudo gedit /var/lib/polkit-1/localauthority/10-local.d/hibernate.pkla

Finally, 'restart' nautilus by executing nautilus -q and the indicator option should spring up.

  • I tried this in Ubuntu Gnome 14.04 and this is not working... I modified the file at /var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla but nothing happens when I reboot. From the information in another blog, I modified the content of the following file,, /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla This is also not working... Which is the correct file, why this isn't working for me? @DusanMilosevic – Erdnase Jun 7 '14 at 9:58
  • I know this is a very old post, but still for those who are facing this issue: In ubuntu 14.04 LTS, the correct path is /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla. And you have to enable ResultActive=yes at TWO places in that file: both for upower and logind. Perhaps, that's the reason why it wasn't working for @Erdnase . – Prahlad Yeri Nov 1 '15 at 11:07
13

Here is a solution. Hibernate option in desktop session and login screen as below:

Desktop Session :

enter image description here

Login Screen :

enter image description here

First open your terminal and add the following :

enter image description here

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

A txt file now is opened add the following lines :

enter image description here

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Save and reboot your system after that hibernate should appear and function well.

  • Sorry, but this does not help. Nothing has changed. – Dusan Milosevic Feb 26 '14 at 23:24
  • i have tried on a clean copy of ubuntu 12.04 and 13.10 and it worked charmed on both , try to undo any changes you have made before , it should work – nux Feb 26 '14 at 23:26
  • you can see i paste to screen shot and they appear on my system man ! – nux Feb 26 '14 at 23:28
  • Could you verify? There is a hibernate when I restart computer, bu not when I log out or switch account. That's the problem. – Dusan Milosevic Feb 26 '14 at 23:29
  • 2
    That works fine in Ubuntu 14.04, both in desktop and in login screen. Before doing this, it may be useful to check that the computer can hibernate. Try sudo pm-hibernate from terminal. If that doesn't work, make sure your swap partition is at least as large as your memory: hibernation works by copying the content of the memory to the swap. – jplandrain Jun 5 '14 at 12:13
9

The configuration for hibernation already sits in file

/var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

Just open this file and enable hibernation: ResultActive=yes The resulting code looks like this:

[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

and

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

That's all. Now you will see hibernate option in power dialog and login

  • This should be the top and accepted answer. – Cas Jul 22 '14 at 14:01
4
+50

That's a bug, which will hopefully be solved in Ubuntu 14.04. It is impossible to enable hibernation in login screen.

  • 1
    isn't it enabled as my answer ? – nux Mar 1 '14 at 22:00
  • Maybe the bug doesn't effect all users. – Dusan Milosevic Mar 1 '14 at 22:09
  • 2
    Got a link to the bug? – Seth Mar 7 '14 at 16:27
3

If you have a multiple-user setup in Ubuntu, you´ll need to also add this snippet:

[Re-enable hibernate for multiple users by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes
  • Thanks, this solved it for me. I believe that most if not all Ubuntu systems these days are "multiple-user", even if there is only one user account set up. – Micheal Johnson Nov 19 '15 at 21:14
0

The reason why hibernation is not present is because Ubuntu’s Hibernate feature has always not been working well in many computers. For new hardware models, the Hibernate feature often don’t work by default. In some instances, the Hibernate feature will even lead to data loss.

But if u wish to use it u can do as follows:

  1. Hibernation is in "Power -> When power is critically low".

  2. to include hibernation button:

    First test whether your computer supports hibernation by typing the following codes in the terminal:

    pm-hibernate
    

    if it goes to hibernation follow the next step:

    a. open the file :

    sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla
    

    b. then edit as follows:

    [Re-enable hibernate by default]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes
    
  • This is not what I asked. Please remove this answer, as it does not answer my question. Hibernation works fine for me, but hibernation button is missing in login screen. – Dusan Milosevic Feb 26 '14 at 9:10
  • 1
    I think this answer is OK for people who don't care that much for hibernation and would rather keep the system stable. I for one decided to ditch hibernation after reading it. – bcelary Apr 18 '14 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.