4

My new desktop computer runs almost silently under Windows, but the fans seem to run on a constantly high setting under Linux. Psensor shows that the GPU (with NVidia drivers) is thirty-something degrees and the CPU is about the same, so it's not just down to Linux somehow being more processor-intensive.

I've read that the BIOS controls the fans under Linux, which makes sense given the high fan speeds when in BIOS as well. It's under Windows, when the ASUS AI Suite 3 software seems to take control, that the system runs more quietly and only speeds the fans up when required. So is there a Linux app which offers a similar dynamic control of the fans, or a setting hidden somewhere in the ASUS BIOS which allows the same but regardless of the OS?

EDIT - I've tried using lm-sensors and fancontrol, but pwmconfig tells me "There are no pwm-capable sensor modules installed". This is after the sensors-detect command does find an 'Intel digital thermal sensor', and despite the sensors working fine in apps like psensor. Help getting this to work would likely solve the problem.

  • 1
    Is it the case/cpu fans or the GPU fan that's stuck on high? Different things control them so it's fairly important. – Oli Jun 1 '14 at 14:28
  • I'm confident it's the case fans. On Windows, OpenHardwareMonitor says the GPU fan is at 37% and the Nvidia Linux app also says 37%. – Sman789 Jun 1 '14 at 16:26
  • 1
    Well that's something at least. Does this help at all askubuntu.com/questions/22108/how-to-control-fan-speed ? – Oli Jun 1 '14 at 17:16
  • I can't get any further than sudo pwmconfig, because I get: "There are no pwm-capable sensor modules installed". This is after the sensors-detect command does find an 'Intel digital thermal sensor'. – Sman789 Jun 1 '14 at 18:06
  • 1
    Updating the BIOS has had no effect, I still get "There are no pwm-capable sensor modules installed" when I run pwmconfig (required for fancontrol). But on the plus side, it does boot faster now :D – Sman789 Jun 6 '14 at 16:46
0

The Asus Z87-A has a Nuvoton NCT6791D SuperIO chip to read temperatures and fan speeds and control the fans. Instructions on how to read and control the fan speeds are given here fan configuration of Z97-E under OpenSUSE. They are for OpenSUSE and the Z97-E motherboard but the process will be pretty much identical for the Z97-A under Ubuntu.

0

I have the same problem. If you add the kernel parameter

acpi_osi=

(and nothing after the = ) my case fans stop running at maximum speed and its work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.