I hope this is not a duplicate and will not be seen as one. I have browsed all the answers and solutions on this forum plus everything I could find on google.

My problem is that when I install NVidia 331 drivers (ether from NVidia website or any other source) after random amount of second (not more then 2-3 minutes) whole graphics freezes and there is no response from anything. Can't even get into terminal. There is no crash report or log of any sort. It just hangs. I have tried so far:

  • nvidia drivers
  • xedgers drivers
  • removing bumblebee
  • using clean ubuntu install
  • using ubuntu after apt-get upgrade
  • using upgrade -> linux-headers-generic
  • installed by nvidia script or from apt-get install nvidia...

Every time drivers are installed with no errors, everything works for few seconds and then stops. If I switch to terminal (any of text terminals) graphics will not freeze until I'll get back to unity. The only way to fix it is to purge everything that's connected to NVidia and revert to NVidia-319. Any ideas where to start looking for source of problem or how to eliminate freezing of graphics?

My spec:

  • Ubuntu 13.10
  • Compaq Presario CQ60-114EM
  • Microprocessor - 2 GHz AMD Turion X2 Dual-Core Mobile Processor RM-70
  • Memory - 4GB
  • Video Graphics - NVIDIA GeForce 8200M
  • Hard Drive - 160 GB (5400 rpm)
  • Display - 15.6" Single channel LVDS HD BrightView (1366 x 768)
  • nvidia.331 does not support GeForce 8200 anymore unfortunally trustys nvidia-319 is a 331 the older 319 debs dont work on 3.13 kernels you have to fall back to an older kernel (3.11) if you want to have nvidia (e.g. vdpau) support regards thomas – coastgnu Feb 11 '14 at 8:29
  • Same problem here - thought that my PC has an defect until I tried to boot without NVIDIA, until than it became clear the buggy Nvidia drivers again :-( I could uninstall the driver by switching quickly to the text-console with Ctrl-Alt-F1 and removing the nvidia-packages. The quick switch to the text-console seems to avoid the system from crashing. (3 years ago, NVIDIA "forgot" also to support this chipset with their Linux driver). Got fixed later - seems to happen again. Really thank you for pointing out the problematic versions, as mentioned by the other guest atleast to the driver document – user249663 Feb 18 '14 at 18:27
  • Have you tried the different approaches mentioned in: askubuntu.com/questions/61396/installing-nvidia-drivers/… – Luis Alvarado Mar 7 '14 at 16:46

Since we are talking about a Mobile (integrated) video card, I would recommend checking the temperature of the video card while using it. Just leave open the nvidia-settings gui app on the temperature section:

enter image description here

If you see the temperature going up very fast then you have a fan/air flow or cooling system problem. I for one have had a couple of this and were solved by disasembling the laptop and cleaning the area. Normally a lot of dust or simply cloaked air flow can cause this. On other models the "smart" idea of having the cpu and gpu on the same place created the problem. I also recommend using the Nvidia PPA because they have:

  1. Been checked for compatibility with Ubuntu
  2. Have the latest official updates.

NOTE - Be aware of an issue you might encounter.

But as a first step, check to see if the air flow is working correctly and do a bit of cleaning on that zone, check the temp of the video card (also check the cpu) and keep the rules on how to use a laptop handy like not working on one with the bottom completely covered (like working in bed) or using graphic intensive apps and not checking the temp.

  • I will say that normally I would agree with overheated CPU and GPU, but this is not a case this time and I can guarantee this. Has to be something else. – user245463 Feb 20 '14 at 19:58
  • @user245463 Have you had any new information about this issue? – Luis Alvarado Apr 13 '14 at 19:30
  • No. Still same problem. Even tried ubuntu 14 and still nothing – user245463 Apr 27 '14 at 11:20
  • If you already did a physical clean up (even with pressured water) and tested other Nvidia versions (including Nouveau) and Ubuntu versions (previous ones) and still the problem is there, you might be getting to the point that the hardware has a problem no matter what OS or driver you use. – Luis Alvarado Apr 27 '14 at 17:10
  • 1
    So let me recap. Laptop is clean of dust and customise do have better venting so AMD on full load has 65° and NVidia 55° after hours of working. On Windows 7 and 8.1 all official drivers work perfect even latest beta. On Ubuntu 12 and 13 only 319 is stable. On Ubuntu 14 at the moment I have to use 304 as later versions don't seem to fully agree. I can provide full logs of whatever you want. Don't mind reinstalling it as long as I can find out how to fix it. – user245463 Apr 28 '14 at 18:10

protected by Community Feb 18 '14 at 21:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.