2

I have a fresh install of Ubuntu 13.10 with the latest Nvidia drivers installed. However, when I run steam I am presented with the following message:

steam opengl glx context is not using direct rendering

I believe this is something to do with not having the correct 32 bit library, however I did install the Nvidia 32 bit libraries when I installed the driver. Running Steam from the terminal I can see that Steam is failing to find the 'swrast' driver which it shouldn't be looking for anyway.

  • I just yesterday read somewhere that a user reported on his system software rendering was used, and the advice was to add that user to the video group. He reported back that this fixed the issue for him . I don't know if yours is the same problem, but probably worth a try. (Sorry, but I really don't remember where I read that.) – Axel Feb 6 '14 at 17:37
  • I've just added myself to that group and I'm still having the same issue - thanks for the suggestion though! – dnlbaines Feb 6 '14 at 22:09
  • To anyone reading this later, don't forget to log off and log back on after adding yourself to the video group, so that your permissions get updated. – jpaugh Apr 27 '16 at 0:24
-1

I solved the issue by removing and purging my previous Nvidia driver and upgrading to the latest beta Nvidia Driver 334.16. I also installed a number of 32 bit libraries which were suggested on various websites which might have contributed to the resolution of this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.