0

My Ubuntu 12.04 system hung. I had to force power it off. It now boots only into console mode.

On booting, I catch a glimpse of "cannot write bytes", but there is nothing in the boot log.

I have tried booting recovery mode from grub, and when I run graphics in failsafe mode, I'm getting a Screen(s) found, but none have a usable configuration.

I have read this post, and applied the instructions, but I still don't boot into the desktop. I have looked in syslog and cannot find an obvious culprit.

unity --reset fails indicating a bunch of errors, including D-BUS not running and "did I just try to reset in a tty".

I like to think I can diagnose a lot of Linux problems, so I am asking more for things to check than necessarily an answer to fix this, but an answer would also be helpful.

Here is the log requested in the comment:

[    17.224] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    17.224] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    17.224] (II) Loading /usr/lib/xorg/modules/libfb.so
[    17.224] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    17.224] (==) NVIDIA(0): RGB weight 888
[    17.224] (==) NVIDIA(0): Default visual is TrueColor
[    17.224] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    17.224] (**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "CRT-0"
[    17.224] (**) NVIDIA(0): Option "MetaModes" "1280x1024 +0+0; 1280x960 +0+0"
[    17.224] (**) NVIDIA(0): Enabling 2D acceleration
[    17.225] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[    17.225] (EE) NVIDIA(0):     system's kernel log for additional error messages and
[    17.225] (EE) NVIDIA(0):     consult the NVIDIA README for details.
[    17.225] (EE) NVIDIA(0):  *** Aborting ***
[    17.225] (EE) NVIDIA(0): Failing initialization of X screen 0
[    17.225] (II) UnloadModule: "nvidia"
[    17.225] (II) Unloading nvidia
[    17.225] (II) UnloadModule: "wfb"
[    17.225] (II) Unloading wfb
[    17.225] (II) UnloadModule: "fb"
[    17.225] (II) Unloading fb
[    17.225] (EE) Screen(s) found, but none have a usable configuration.
[    17.225] 
Fatal server error:
[    17.225] no screens found
[    17.225] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    17.226] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    17.226] 
[    17.226]  ddxSigGiveUp: Closing log
[    17.226] Server terminated with error (1). Closing log file.

After resetting the X11 config file, rebooting, and running gksudo nvidia-settings, I get an error

(gksudo:1993): Gtk-WARNING **: cannot open display:

  • Try to remove (after a backup, obviously) your /etc/X11/xorg.conf. It could have been tweaked by some driver and it is not removed when re-installing a modern X. Moreover, you should add some information to the question, like for example the graphic card/drivers used and the X log in /var/log/Xorg.0.log --- in this file you should have the error that makes the X server crash. – Rmano Feb 5 '14 at 19:16
  • I'm confused about the last part of your instructions involving adding info to the log file, and the removeal of xorg.conf didn't fix the problem. – octopusgrabbus Feb 5 '14 at 19:19
  • @Rmano is asking you to include information to your question (by editing your post) from your log file, not to the log file. – hmayag Feb 5 '14 at 19:38
  • did you try to: sudo nvidia-xconfig then reboot and run gksudo nvidia-settings and reply what you got. – JoKeR Feb 5 '14 at 20:27
  • 1
    ok but I asked you if you could bring the output here. You need to activate Nvidia driver and the command sudo nvidia-xconfig activates it and after you need to restart X the best way to reboot. If the restricted driver remains unactivated after attempting to activate it in the Additional Drivers dialog, you may not have the appropriate linux headers installed to compile the driver. Ensure that the linux-headers-XXX and linux-restricted-modules-XXX packages are installed, where XXX matches the version of the kernel you are using. To check linux kernel type uname -a – JoKeR Feb 5 '14 at 21:04
1

the solution lies herein purge/remove/reinstall nvidia driver, also do not forget to check additional drivers and choose and activate the right one. And you can check it with:

jockey-text -l

to activate and config the driver:

sudo nvidia-xconfig

to start it:

gksudo nvidia-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.