I've installed the current nvidia restricted driver and rebooted my machine and now I get a black or blank screen.

How can I fix this?

  • (Those going for the bounty on this question, there's no need to redo all the optimus options, just add those existing answers as links in an all encompassing answer, cross-link as much as you can!) Jul 12, 2012 at 0:48
  • 1
    A lot of the answers will fail using "sudo apt-get install nvidia-common" because of this bug: bugs.launchpad.net/ubuntu/+source/nvidia-common/+bug/981874 Oct 17, 2012 at 19:13
  • could be an issue with the kernel version... Install ukuu and install a newer version of kernel. You can always revert back to the one you are using though. Nov 14, 2018 at 12:33

15 Answers 15


Remove all Nvidia-related packages

  1. Log in to a terminal: Ctrl+Alt+F1 (terminal is visible with a blank screen)

  2. sudo apt-get remove --purge nvidia-*

Start from scratch

  1. sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall everything

  1. sudo apt-get install nvidia-common
  2. sudo apt-get install xserver-xorg-video-nouveau
  3. sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure the X server

  1. sudo dpkg-reconfigure xserver-xorg

Source: Ubuntu Wiki

  • 4
    Finally, that fixed it (omitted "Start from scratch" stage - didn't fancy uninstalling xserver!) but did all the other steps and it works a treat. Many thanks! Apr 10, 2013 at 9:56
  • 6
    That wiki is outdated. the nvidia-settings --uninstall doesn't work, for example.
    – NoBugs
    Jan 11, 2014 at 22:35
  • 2
    @NoBugs: yes, but following the steps still fixes the graphics on 14.04 after reboot
    – jfs
    Sep 9, 2014 at 20:22
  • 1
    When I run sudo apt-get install xserver-xorg-video-nouveau I get the following message: The following packages have unmet dependencies: xserver-xorg-video-nouveau : Depends: xorg-video-abi-15 Depends: xserver-xorg-core (>= 2: Recommends: libgl1-mesa-dri (>= 9.0) E: Unable to correct problems, you have held broken packages. " Any idea what to do in this case?
    – Cleb
    Jun 2, 2015 at 16:44
  • 3
    No longer working as of April 2016. None of the commands after sudo apt-get install nvidia-common work. This is on Ubuntu 14.04 on an Asus G751JM (nvidia GTX 860m)
    – sgarcia
    Apr 13, 2016 at 18:07
  1. Remove any drivers that may be causing the issue,

  2. open the terminal and type ( open it from the dash, using the ubuntu icon on the left corner)

     sudo apt-get --purge remove nvidia


     sudo apt-get --purge remove nvidia-current

    (Depending on which one you have installed) or deactivate them from the restricted driver settings.

  3. reboot.

  4. then on a terminal type this:

     sudo apt-add-repository ppa:ubuntu-x-swat/updates
     sudo apt-get update
     sudo apt-get install nvidia-current nvidia-settings
  5. reboot.

  • 2
    This worked for me, but left me with 640x480 equivalent problem to askubuntu.com/questions/201123/…. Also, use Shift/Esc during boot to enter linux equivalent of 'safe mode' so that you can execute these commands
    – Alex
    Oct 22, 2012 at 0:29
  • Damn rep won't let me edit my own comment - just wanted to add that the solution proposed for the 640x480 problem in the question referenced above works fine, so don't let that hold you back.
    – Alex
    Oct 22, 2012 at 0:46
  • 2
    If my computer starts up with a blank screen, how can I open a terminal to type those commands? The screen is blank! Nov 11, 2012 at 4:35
  • @StefanLasiewski askubuntu.com/questions/162075/… Nov 11, 2012 at 7:42
  • The info here really should be added to Marco Scannadinari's answer above to improve/expand on already existing answer
    – geezanansa
    Jan 31, 2015 at 8:26

In my case it was a problem with the monitor giving my Nvidia GPU a bad EDID

To debug your error, you can add this line to the screen section in the the /etc/X11/xorg.conf file

Option         "ModeDebug" "true"

Now check your /var/log/Xorg.0.log file.

If you find an error like this:

NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI

Then you can resolve it by adding this line to the device section

Option         "IgnoreEDIDChecksum" "DFP"

Maybe Ubuntu IT'S working but using another card output. For me, my nVidia GeForce 7300 has 2 output, a VGA and a DVI. It seems like the default output when you install the drivers is to DVI but I don't have a DVI monitor so I managed to get to Recovery Mode (available in GRUB when you boot) and type this:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Now Reboot.

This command directs the same graphics to both outputs. From there on, you can keep experimenting with this nVidia utility until you get what you want. For more information type:

nvidia-xconfig -A | less

Hope that helps.


Press Alt+Ctrl+F1 to get to tty1 (terminal), then run this:

sudo apt-get --purge remove nvidia*

That will remove any nvidia driver packages. If that still doesn't work, try this also:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

That will remove a corrupted xorg configuration file if it exists. You will need to reboot after finishing these commands. (Ctrl+Alt+del)

PS. If you have an nvidia optimus card, do not install the x-swat or any other nvidia drivers. The best working drivers for nvidia optimus cards come from the bumblebee project.

  • Is the purpose of this to just default back to the nouveau driver ?
    – ychaouche
    Sep 11, 2019 at 11:01

This happened to me when running an AMD cpu: Learned it was an IOMMU/AMD -v Bug = Incompatible with Nvidia. Disabling Virtualization bios settings fixed this.


Does that thread on Ubuntu Forums help you?

In short, it seems that the linux-header packages for some of the kernels (notably the PAE kernels) are not properly installed, and the nvidia driver compilation fails silently when installing the nvidia packages.

  • Thx for your post. But see edit 5! What can i do? May 13, 2011 at 21:24

Regarding the topic title: What is the current restricted nvidia driver version used in Ubuntu natty?

You can find anything about releases, versions, bugs, requested features on Launchpad. To understand what it is about you can take their tour.

The question about the latest version of the nVidia driver can be found on “nvidia-current” binary package in Ubuntu Natty i386. So as of 2011-04-20 the latest version is 270.41.06-0ubuntu1. But that is not necessarily the recommended one. The latest one for me always seems buggy (like 'tearing' etc).


Instead of using nvidia-current you should really try to use an older nvidia driver e.g. the 173.xx. This solved the problem for me. Just start jockey-gtk and chose the 173.xx driver. Than reboot your system.


Try in /etc/default/grub:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

Replace "1680x1050x32| with your native resolution (to get it run vbeinfo in the grub console when booting).

Then in /etc/grub.d/00_header:

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Update grub:

sudo update-grub

Might work...


Try acpi=off. That solved my booting into blank screen issue for Ubuntu 11.10.

  • The original question was an old one. The reason this probably wasn't suggested at the time is that the problem occurred only after the proprietary driver was installed. A better answer might be to revert to the last known working driver, then try alternate nvidia drivers that have become available. Nov 11, 2012 at 0:08
  • Where should acpi=off be set?
    – Magick
    Jul 22, 2019 at 3:44
  • @Magick at the grub menu entry at boot time (press e to access). Then look for the line which passes options to the kernel (starts with "linux"). See con-f-use answer below : askubuntu.com/a/43691/550380, this is will make the option permanent.
    – ychaouche
    Sep 11, 2019 at 11:05

I got a blank screen as well, but this was on a laptop with and nVidia optimus card 4200m. Optimus does not seem to be supported well on Ubuntu. I had to disable optimus from the bios and then reinstall the nividia driver. More here if you want to read http://developerslog.org/?p=69

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Oyibo
    Nov 11, 2012 at 8:49

I was getting a black screen when booting. I have a NVIDIA 6200 graphics card. Renaming xorg.config and rebooting worked for me. The xorg.config file created by nvidia-xconfig: version 304.51 ([email protected]) was causing the problem.


The biggest trouble I had was getting a Macbook Pro to install the Nvidia drivers!!!

The solution is to change the Master Boot Partition to REMOVE EFI and go with Legacy MBP.

This is discussed on a few webpages but is not so easy to follow.


Using this idea, I booted from a Live CD and then using Gparted removed the EFI boot partition, changed it from EFI to FAT32 and then using Boot-Repair rebuilt it as a legacy boot using the main Partition with 13.04 64 bit installed



Insert Live CD - Boot up as try Ubuntu Run Gparted - Change EFI boot partition from EFI to FAT32.

open a new Terminal, then type:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

  • Press Enter.

  • Then type:

sudo apt-get install -y boot-repair && (boot-repair &)

In boot repair select ADVANCED OPTIONS

Uncheck Use the Standard EFI File under main options Uncheck Separate /boot/efi partition under GRUB LOCATION

follow prompts on how to use the legacy Boot loader that Boot Repair will give you.

Now install and load the NVidia drivers as many post

I used the method 2 on this page http://www.dedoimedo.com/computers/ubuntu-ringtail-nvidia.html

I was working on this for probably 18 hours and tried EVERY option available. I mean every possibly way to install these friggin drivers, and this was the only solution that works for the Macbook Pro 7.1 Running 13.04 with Nvidia_current (nvidia_304)


I've tried everything here and the solution for me was to switch to lightdm, works perfectly now!

  • How do you switch to lightdm?
    – Magick
    Jul 22, 2019 at 4:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .