Neither lightdm not gdm actually allow me to log into any account but guest. My solution, so far, has been to drop to the shell (ctrl+alt+f1) login, then sudo startx. the xauthority file never locks without sudo.

Doing it this way, I'm root. I have not been able to successfully access a non-root terminal from root. As a consequence when I want to run some file or program which objects to being run as root, I have to switch to the guest session.

I really can't believe how broke this release was, the same thing happened on 2 computers. I don't so much mind going around the normal login, however the unwanted root access this creates is a major issue.

edit: after further investigation I found that su username was exactly what i was looking for to de-root a root terminal

1 Answer 1


I had a similar issue with a Lubuntu login loop.

@NikTh suggested this which worked for me:

"Try to remove the file ~/.Xauthority . Login from a TTY (CTRL+ALT+F2) and"

rm ~/.Xauthority .

"Be careful with the dot and the capital X. This file is hidden in your home directory. It is safe to remove it. It will be generated again in next login. After the deletion restart lightdm."

sudo service lightdm stop ; sudo service lightdm start
  • Tried that but when I login I just get a black screen for a long time, so I dropped back to the shell and sudo startx brings up the desktop.
    – user244661
    Feb 10, 2014 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.