2

I have two Intel Core2 Duo desktop PCs both connected to an iiyama Prolite E2407HDS monitor through a VGA switch box. I've just reformatted the hard drive and installed Ubuntu 12.04 on one.

In descending order of priority, the things I want to be able to do on the Ubuntu machine are...

1: Run Google Chrome to access the Internet
2: Run Foobar2000 to play music
3: Run VLC to watch movies (through TV connected as a second monitor)
4: Code development (specifically, port my Foobar speech plugin so I can use it without Windoze)

So far the only "non-default" thing I've done is to install Chrome as the default browser. That was easy, because it was already available in the Ubuntu Software Centre which I accessed from the Dashboard just using the mouse.

The Ubuntu machine has an ATI Radeon HD 4300 video card, which is more than capable of supporting the 1920x1080 resolution I'm used to on this monitor. But when I go into System Settings and select Screen Display, I'm only offered a choice between 1024x768 or 800x600.

I downloaded *iiyama_drivers.zip,* opened it, and found a folder containing three files E2407HDS with extensions *.cat, *.icm, and *.inf, but I don't know what to do next.


I'm writing this question on the other PC (running Windoze XP because I'm finding the relatively lo-res Ubuntu browser window awkward). Both machines are powered up, and I've been using the switch box to swap between them. The Ubuntu system has just "auto-updated" itself with several things, including something called fglrx which appears to be a proprietary driver for ATI Radeon video cards. But the Additional Drivers facility in Ubuntu still says No proprietary drivers are in use on this system, and the Screen Display facility still only offers the lower resolutions.


Please note that I'm a complete noob as regards Unix/Linux/Ubuntu. I don't even know how to access the "command-line prompt", let alone what or why I should type anything in there. And I'm leery of experimenting because short of re-installing I've no idea to get back a functional system if I mess up.

So - how can I easily (ideally, using just a mouse) improve my screen resolution?

(I know I should only ask one Q per post, but a link to "system snapshot backup" would be good, too.)

  • Good to see you away from your usual haunts :). You're quite right, fglrx is the proprietary driver for ATI cards, it sounds like it's been installed but not activated. Usually, restarting your machine should suffice. Please let us know if you still can't set your resolution after restarting. – terdon Feb 4 '14 at 18:08
  • @terdon: I've just rebooted (twice). Nothing has changed in terms of being able to set a higher resolution, but History in Ubuntu Software Centre says the fglrx thingy was updated earlier today. – FumbleFingers Feb 4 '14 at 18:26
2

I'm having a similar problem with my AMD HD 7770, but have gotten at least so far in finding solutions, and figure this might help you a bit. The first, which does I'm afraid require the Terminal, can be found by following the instructions found here: http://community.linuxmint.com/tutorial/view/877 I would however do step 3 and 4 first, as in my experience they will undo progress made in steps 1 and 2, but don't require them to work. I have however found the X.Org driver to be useless for gaming on my machine. I don't know whether the case would be the same for you. The Terminal (which is the equivalent to the Command Prompt in Windows) should be very easy to find. Simply search for it in the Dash (accessed through the Ubuntu Button at the top-left).

The other option is to switch to the proprietary driver. This can be done going into Settings>Software and Updates>Additional Drivers. You'll probably need to restart for the changes to take effect. For me this has given a maximum resolution of 1600x1200, which I know isn't ideal, but is a step in the right direction I'm sure. In addition, games have worked well, so that's something. It does appear though that this won't work with the first fix for whatever reason. I've tried. If you were to do this fix, I think the big problem now would be a cap that can't be edited in Catalyst Control Centre, which is annoying, even when root.

I don't know how far this will get you, but I hope you can pull something from this if you haven't found a fix yet. :)

| improve this answer | |
1

The iiyama driver is for Windows only.

Installing fglrx is the correct way but it does not activate the driver. I don't know why your Ubuntu does not show the driver in Additional Drivers but you can activate it with

sudo amdconfig --initial

and it would be activated after reboot. You would need to run this in terminal, there is no other way if Additional Drivers are not working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.