58

Every now and again phpStorm will lose input from my keyboard. I can still click around, but it will not register any keys. Other windows are fine. It takes a phpStorm restart to bring them back. It seems to happen most when I Control+Tab between open tabs

I am running: Ubuntu 13.10 phpStorm 7.1 JRE 1.7.0_51

3
  • This is still experienced in Ubuntu 14.04.3 phpStorm 9.0.2
    – phazei
    Commented Oct 13, 2015 at 16:27
  • phpStorm is a paid app. Don't they support their software? This isn't really anything to do with Ubuntu I don't think.
    – Goddard
    Commented Nov 19, 2015 at 3:15
  • @Goddard this is not just phpStorm nor Ubuntu issue. It is X window/ Ibus problem with any Jetbrains product really.
    – ruuter
    Commented Feb 9, 2016 at 10:05

5 Answers 5

58

You should look at this bug here: http://youtrack.jetbrains.com/issue/IDEA-79312

It's exactly your issue, and it has a potential workaround:

sudo ibus restart

Hope that helps!

8
  • 1
    Sweet, fixes it for me and much quicker than a restart
    – STW
    Commented Aug 15, 2014 at 19:58
  • 2
    Watch out latin keyboard people, it worked for me but made my keyboard switch to QWERTY. Had to input in a terminal the "setxkbmap fr" command to make it AZERTY again.
    – Mat
    Commented Aug 27, 2014 at 9:15
  • 1
    @STW but the problem still exists and it's keep loosing focus
    – Gtx
    Commented Sep 24, 2014 at 15:00
  • 3
    @Gtx - yep, it's not a fix but it will regain keyboard input (at least for a while). It's best to give feedback to Jetbrains so they'll hopefully work on a fix.
    – STW
    Commented Sep 24, 2014 at 15:04
  • This worked for me to, but I always need to run that command again to regain my keyboard input later. Is there a way to trigger that command when the keyboard lose focus?
    – themhz
    Commented Feb 3, 2016 at 15:14
5

Seems like the correct issue/bug for OP is actually this: IDEA-78860

This is not a Ubuntu version specific, but X Window / IBus problem and it is still happening in Ubuntu 14.04 with IBus < 1.5.11

Option 1:
Update IBus to 1.5.11 or higher Check this answer on how to update ibus on ubuntu

Option 2:
Official workaround, is to add following line to your ~/.profile

export IBUS_ENABLE_SYNC_MODE=1

Remember you have to restart your session (logout) for this to take effect.

Option 3:
The most universal workaround is still ibus restart, but I think it is worth to quote the assignee of the issue:

Restarting IBus isn't recommended (may crash the IDE later)

Yes, that may happen sooner or later. Also this resets your keyboard layout to default (mostly english). So you'd have change that back every time you restart ibus.

Another option is to disable ibus, but this really is not a solution for people who do not have US kb layout.

0

i prevent this issue, by a changing "Keyboard input method system" (System settings > language support) from "IBus" to "none".

https://stackoverflow.com/a/33684325/250814

-1
ibus restart && sleep 1 && ibus engine xkb:se::swe

worked for me

2
  • 2
    this makes your keyboard layout swedish. This should NOT be an answer for this case. Commented Dec 5, 2015 at 3:31
  • @igorsantos07 This restarts ibus and resets KB locale to swedish yes, but you can change it to whatever KB layout you have. Point is, restarting ibus will reset you KB layout to default, english mostly.
    – ruuter
    Commented Feb 9, 2016 at 9:40
-1

you can try removing the .idea folder at the root of your project, then try File → Invalidate cache and restart.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .