3

Im running Keepass2 version 2.23. I try to get the plugin running on Ubuntu 13.10. When I check Google I see that a lot of people have it running in older versions. Is there a way to run something like this in compability mode? Or do I have to look for an older version of Keepass 2?

I've tried:

  • KeePassHttp.plgx

And the two DLL files:

  • Newtonsoft.Json.dll
  • KeePassHttp.dll

Keepass is working perfectly. I have the problem on several computers. Hereby the screenshot, after I put the keepasshttp file in de installation directory.

enter image description here

2

I had this problem and you end up having to do an sudo apt-get install mono-complete to get any of the plugins working.

Found the solution here: http://www.maketecheasier.com/integrate-keepass-with-browser-in-ubuntu/

0

Download the file from this link Keepasshttp

Then click 'view raw' to download the file. Now try this file it will work.

Alternate Download Link

Unzip and use the file.

Reinstall it again...

Press Alt+Ctrl+T to start terminal and run following commands one by one.

sudo apt-add-repository ppa:jtaylor/keepass  
sudo apt-get update  
sudo apt-get install keepass2 mono-complete

Follow this for using it with firefox
How to integrate KeyPass2 and Firefox

Follow this for using it with Chromium
How to integrate KeyPass2 and Chrome/Chromium

  • I've tried this already as you can see in my question. This does not work. – r00n Feb 8 '14 at 22:31
  • Reinstall it and see if it works with firefox or not. Keepass2 will not work if you don't have mono and if you didn't download the keepasshttp file correctly. I've given you the steps above, follow it and you should not have any problem. If still face problem take a snap shot of your error and show it to us. – Faisal Feb 15 '14 at 7:02
  • I added the info you requested to my question. I hope it gives you more insight to my problem. – r00n Feb 16 '14 at 15:45
  • Try Alternate Download Link from above... – Faisal Feb 24 '14 at 3:17
  • I've tried it and get exactly the same error as before. Filesize of the old and new file are exactly the same. (seems that it is the same file) – r00n Feb 28 '14 at 11:48
0

Be sure to chmod 644 your KeePassHttp.plgx file. Mine was 640 and I got the same error. KeePass2's error messages are obviously a bit misleading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.