Router Model No.: TL-WR842ND

After reading this article, I carry on the installation but it does not work. This is the properties page:

enter image description here

I have attempted to print test page but the status shows me "Processing - Not connected?". The following are the screenshots.

enter image description here enter image description here

If I just directly use the wire to connect the printer, it works. [usb://FUJI%20XEROX/DocuPrint%20P205%20b?serial=WKK-850460]

I have also tried:

No one works.

This is the status of my router. enter image description here

Could you teach me how to configure the setting?

Thank you for your attention.


Printer Server : Online enter image description here

USB Connected enter image description here

Power ON enter image description here

It works well on windows only with this official program. enter image description here

  • I suggest you try: ipp:// – chili555 Feb 4 '14 at 15:24
  • 1
    Can you confirm that, in the router, the print server service is set to Online? – chili555 Feb 4 '14 at 15:57
  • 1
    I would also try https, ipps and also ipp14. Try with and without the :631 printing port. – chili555 Feb 4 '14 at 17:18
  • 2
    The problem has not been resolved. I have contacted TP-link for a solution but they said that they do not support Linux. They do not have the solution. – Casper Nov 30 '14 at 17:11
  • 1
    Have you tried upgrading the router's firmware to one of the open distributions? (Just a dumb question as nothing seems to work) – Fabby Dec 6 '14 at 21:42

I understand from the screenshot of your router, 192,168.0.1 is your router's address, and you have a separate "printer server" box (TP-PS110U)connected to the router by ethernet on one side and your printer's USB on the other side.

Step 1 says to go directly to step 4... However, step 3 explains the printer spooler web interface at -- it may be worth a visit there to check everything is in place.

According to Step 6, the spooler is at by default (to confirm with the information found on the web interface of the print server at, that's where you should find your printer, not at, which is your router.

Does it change something?


Looking at your link that you referred to as your instrucible, it looks like you skipped step 3.

Step 3 Open the web browser (like Firefox) and type in the address bar. Then please go to Setup->TCP/IP page, change the IP to and click Save & Restart button.

If you had done step 3 then your ip address should be

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.