-1

I am running Ubuntu 13.10,

$ uname -a

Linux N5010 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:22:01 UTC 2014 x8664 x8664 x86_64 GNU/Linux

I have tried installing synaptic via command line (both apt-get & aptitude) or via software-center, but the result is always the same - it will not start! I can successfully execute:

$ synaptic --help

synaptic for Debian 0.80.2

Usage: synaptic [options]

-h This help text -r Open in the repository screen -f=? Give an alternative filter file -t Give an alternative main window title (e.g. hostname with uname -n)

-i=? Start with the initial Filter, with given name. -o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp --upgrade-mode Call Upgrade and display changes. --dist-upgrade-mode Call DistUpgrade and display changes. --update-at-startup Call "Reload" on startup. --non-interactive Never prompt for user input. --task-window Open with task window. --add-cdrom Add a cdrom at startup (needs path for cdrom). --ask-cdrom Ask for adding a cdrom and exit. --test-me-harder Run test in a loop.

However when attempting to execute it, I get:

  • Error in `synaptic': malloc(): memory corruption: 0x00000000028754f0 *

Note: The address will change on every new/reinstall!

I have tried:

$ sudo apt-get purge synaptic $ sudo apt-get install synaptic

$ sudo apt-get install synaptic --reinstall synaptic

And countless others on the same theme, but the result is always the same. Any help appreciated. Happy to provide any additional information. Have also tried installing via software-center as well as aptitude (just for comparison), but this has the same result.

I have even searched & changed the line in /usr/share/applications/synaptic.desktop, from

Exec=synaptic-pkexec

to

Exec=gksudo synaptic

But it changes nothing. This is even more annoying as everything worked fine before I had to replace my hard disk. So any help greatly appreciated. Thanks.

/vince ..

0

Follow the below steps for debugging.

  • I'd suggest that you take out the disks and make sure that they are OK.

  • If you stumble upon any bad sectors then that means the drive is bad.

  • If the above then replace it and reload the system entirely.

  • Also try doing a memtest from the live cd menu.

I'm pretty certain that this is hardware issue.

  • Hi, thanks for that, but have done all the above. * Done, they are - The disk is new & has no bad sectors - Have down a reinstall, where I removed & reinstalled. Same problem - Done, all ok – Vince Feb 5 '14 at 21:27
  • Umm, sorry my pointed list did not happen! * New disk, installed ok * No bad sectors, brand new hard drive. Oddly enough synaptic worked fine on the old hard disk which had bad sectors. * Have done a fresh install of Ubuntu 13.10, but the same result * mem test was all ok. Any other suggestions, as I am at a lose. Thanks. – Vince Feb 5 '14 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.