I have a Canon iP1600 connected wireless through Win system laptop, I just can't install the printer although I've googled and tried various ways recommended. I'm at my wit's end!

  1. Open a terminal by pressing Ctrl+Alt+T.

  2. Connect the printer to the computer--but don't start it!--and run these commands:

    sudo apt-get install libpng3
    sudo apt-get install alien
    sudo apt-get install libxml2
  3. Now download the driver for your printer and install it with these commands:

    cd ~
    wget http://files.canon-europe.com/files/soft24301/software/24301.tgz
    tar -xvf 24301.tgz
    mkdir iP2200_Linux_260
    mv iP2200_Linux_260.tar.gz iP2200_Linux_260
    cd iP2200_Linux_260
    tar -xzf iP2200_Linux_260.tar.gz
    sudo alien --to-deb --scripts *i386.rpm
    sudo dpkg -i *.deb
  4. Now:

    cd /usr/lib
    sudo ln -s /usr/lib/i386-linux-gnu/libpng.so.3 libpng.so.3
    sudo ln -s /usr/lib/i386-linux-gnu/libtiff.so.4 libtiff.so.3
    sudo ln -s libxml2.so.2 libxml.so.1
    sudo ldconfig
  5. Now you have to change the file /usr/share/cups/model/canonip2200.ppd. So you have to run this command in terminal:

    sudo gedit /usr/share/cups/model/canonip2200.ppd

    Add these lines at the end:

    *OpenUI *CNQuality/Quality: PickOne
    *DefaultCNQuality: 3
    *CNQuality 2/High: "2"
    *CNQuality 3/Normal: "3"
    *CNQuality 4/Standard: "4"
    *CNQuality 5/Economy: "5"
    *CloseUI: *CNQuality
  6. Now in the same file (still /usr/share/cups/model/canonip2200.ppd) in the text editor, find these lines:

    *OpenUI *Resolution/Output Resolution: PickOne
    *DefaultResolution: 600
    *Resolution 600/600 dpi: "<</HWResolution[600 600]>>setpagedevice"
    *CloseUI: *Resolution

    Delete them, and replace them with these lines:

    *OpenUI *Resolution/Output Resolution: PickOne
    *DefaultResolution: 600
    *Resolution 600/600 dpi: "<</HWResolution[600 600]>>setpagedevice"
    *Resolution 1200/1200 dpi: "<</HWResolution[1200 1200]>>setpagedevice"
    *Resolution 2400/2400 dpi: "<</HWResolution[2400 2400]>>setpagedevice"
    *Resolution 4800/4800 dpi: "<</HWResolution[4800 4800]>>setpagedevice"
    *CloseUI: *Resolution
  7. Now you have to restart the cups deamon with this command in terminal:

    sudo service cups restart
  8. Turn on the printer.

  9. As the printer starts up, the system will automatically search for driver. Select Canon for manufacturer and select iP2200 Ver.2.60 for the printer model. If the procedure for automatically search the driver don't start, open the dash (for open the dash click the windows key on the keyboard) and search for printer.

|improve this answer|||||
  • I've installed 12.04 beta yesterday. Followed your instructions and printer works a treat. This is the first time I've ever managed to get the ip1600 to work with Ubuntu – user49348 Mar 5 '12 at 20:26
  • It worked fine for a .386, but how can I do it for a 64bit computer (with 64bit ubuntu)? – user53861 Apr 7 '12 at 10:46
  • There is better solution for newest ubuntu's: askubuntu.com/questions/240338/… – Torbins Apr 26 '13 at 19:45

Not the answer you're looking for?Browse other questions tagged or ask your own question.