I have a cd image that is not a .iso but a .cue. I cannot mount it. I use ubuntu 10.10 64 bits, and I've tried a lot of programs. furiosmout just says it is not a image file, and it just didn't work. I found a program (acetone) that can convert .cue in .iso, but it says I need other packages (that I could not come to). I was looking for an easy way. Any help?

  • 5
    Do you have a .bin file to accompany the .cue file?
    – ændrük
    Sep 14, 2010 at 15:12
  • yeah. But it's at home, so just a little latter I'm gonna try the solution.
    – Habkost
    Sep 14, 2010 at 16:39

4 Answers 4


Typically a .cue file will be accompanied by a .bin file that contains the actual image data. If you'd like to convert it to the .iso format, the Iso9660 Analyzer Tool (apt-get install iat) should do the trick:

iat my_image.bin my_new_image.iso
  • 4
    I had to write iat --input=my_image.bin --output=my_new_image.iso --iso for the command to work. Dec 23, 2018 at 19:52
  • Seems like the command line format has changed, I had to use: iat my_image.bin > my_new_image.iso (version v0.1.3) Apr 18, 2020 at 13:51

This has been bothering me in the past and I never did find a solution. I set out for an answer and found it on a whim; these instructions are derived from the script on that site.

You'll need the .bin file that should be accompanying the .cue file. Note the file sizes: the .bin is likely several hundred MB, while the .cue is probably less than one KB. If you have a large .cue file, it's possible it's named incorrectly, so it doesn't hurt to try this anyway:

  1. Install fuseiso (sudo apt-get install fuseiso)
  2. Run fuseiso -p image_file.bin /path/to/mount, and you should see the mount point fill up with files. This can be run as a normal user, and the directory doesn't have to exist.
  3. When finished, run fusermount -u /path/to/mount to unmount and remove the directory fuseiso created.

Hopefully this helps.

  • 1
    I tried it and got errors for an audio CD .bin/cue, which was created by 'brasero' .. This is from info fuseiso: "One major limitation of .BIN images is that fuseiso does not handle .CUE files in any way, and thus can work with only the first track of .BIN images."
    – Peter.O
    Jan 19, 2011 at 3:30
  • I also tried to mount a .bin created by brasero, and get init: wrong standard identifier in volume descriptor 0, skipping... So it looks like fuseiso it doesn't work with brasero's .bin format.
    – mivk
    Apr 23, 2015 at 13:54

And also bchunk can do the same trick as iat:

bchunk IMAGE.bin IMAGE.cue ANYNAME.iso
  • This seems to be more mainstream than iat
    – Luke Dupin
    Dec 20, 2020 at 4:49

The best way is to use cdemu; I regularly use this utility for mounting bin/cue pairs. The program doesn't seem to be in the repositories, but there is a ppa available at Launchpad; you can install it with these steps:

sudo add-apt-repository ppa:cdemu/ppa
sudo apt-get update
sudo apt-get install gcdemu cdemu-client

Just a simple sudo apt-get install cdemu, as suggested here, won't work for this ppa. More information on ppas and how to use them is available here.

As outlined in the man page, and reiterated in this useful article, it is simple to use. You can either use the gcdemu gui or issue cdemu commands in terminal.

Just specify the location of your cue/bin pair (both must be present in the same directory), and run, for example:

cdemu load 0 /home/mike/isos/Timeshock.cue

To check that it has loaded, run cdemu status, which will return:

Devices' status:
0     1          /home/mike/DOS/TIMES/Timeshock.cue
1     0  

To see the device allocation, enter cdemu device-mapping:

Device mapping:
DEV   SCSI CD-ROM     SCSI generic   
0     /dev/sr2        /dev/sg4       
1     /dev/sr3        /dev/sg5 

You can also cd to /media and run ls to show the new entry:

cdrom  floppy  floppy0  ISOimage  Timeshock  ZEN STONE

Strangely enough, I still had to click to mount them in my file manager (Thunar).

You can unload the image pair by specifying the same device (0) used when loading the pair:

cdemu unload 0

If any errors occur, or you can't load or unload your images, just logout and login again.

Side Note: I was able to run Timeshock (a Pinball game) in Wine as the image mounted by cdemu was seen in Wine as H: /media/Timeshock. (The game had been previously installed in Wine) Some games, however, may require the disk to be assigned a D: drive letter in Wine.

You can also use cdemu for many other things than just mounting bin/cue pairs, and it may be very useful to anyone who has specific needs to emulate drives or to mount more unusual image types. More information is available at the official site, which details the options available.

  • 2
    the most advanced and efficently solution, a daemon tools equivalent for linux. May 24, 2017 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.