8

I downloaded and installed Google Earth 6 64-bit from its website. And then like many users, I also encountered the ugly fonts on starting the app. I've tried installing lsb-core and ttf-mscorefonts-installer, but I found that both are already installed. Could someone help me fix this?

1

I've just installed Xubuntu 11.10 on my 64-bit machine, and downloaded and installed the 64-bit .deb package for Google earth 6.2, and had the same problem with the awful font.

I followed the instructions on page http://omgubuntu.co.uk/2012/01/how-to-make-google-earth-look-native-in-ubuntu, and they solved the problem. To paraphrase:

  • First, close Google Earth if it's running.
  • In a terminal emulator, give the following commands:
    • cd /opt/google/earth/
    • sudo rm libcurl.so.4 libGLU.so.1 libnss_mdns4_minimal.so.2 libQtCore.so.4 libQtGui.so.4 libQtNetwork.so.4 libQtWebKit.so.4
  • Use any editor to edit file /opt/google/earth/googleearth -- but you have to do it as a root, so for instance, the following command from a terminal emulator would work:
    • sudo nano /opt/google/earth/googleearth
  • Now add the line export LD_PRELOAD=libfreeimage.so.3 as the second last line of file googleearth -- that is, just before the line LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@" -- and save the file.
  • Obtain the file libfreeimage.so.3 (removed broken link) Edit: Since the link is broken you can obtain the file in this package

  • If your machine is 64-bit, download the file libphonon.so.4 (removed broken link) Edit: Since the link is broken you can obtain the file in this package

  • In a terminal emulator, give the following commands (the ones concerning libphonon.so.4 only if your machine is 64-bit):
    • cd /opt/google/earth/
    • sudo cp ~/Downloads/libfreeimage.so.3 .
    • sudo cp ~/Downloads/libphonon.so.4 .
    • sudo chmod a+x libfreeimage.so.3
    • sudo chmod a+x libphonon.so.4
    • sudo apt-get install libcurl4-openssl-dev libqtwebkit4
  • Restart Google Earth. The fonts should now look normal.
| improve this answer | |
  • 1
    Installing the microsoft fonts fixes this, too. And it is way less complicated. – mniess Mar 26 '12 at 19:53
  • 1
    Well, the person who asked the question did say that they had lsb-core and ttf-mscorefonts-installer already installed, and that obviously didn't help with the problem. – Teemu Leisti Mar 31 '12 at 1:16
  • 1
    deleting all those files ruined google earth stable in 12.04 don't try it. – Joshua Robison Dec 5 '12 at 12:07
1

Ubuntu 16.04.6 LTS

Although the original question was posted 8 years ago in 2011, the problem persists today on July 14, 2019. Eight years ago it was version 11.04 today I'm using version 16.04. The problem today is the font is super tiny on a 4K screen.

I use this script to double the size of fonts in google earth:

xrandr --dpi 192
google-earth-pro

This is on a 4K monitor. On a 2K monitor a 50% increase might suit you better:

xrandr --dpi 144
google-earth-pro

The default dpi is 96 as you can confirm with one of these commands:

$ xdpyinfo | grep dots
  resolution:    96x96 dots per inch

$ grep DPI /var/log/Xorg.0.log
[     9.555] (--) NVIDIA(0): DPI set to (43, 44); computed from "UseEdidDpi" X config
[     9.761] (==) modeset(G0): DPI set to (96, 96)
| improve this answer | |
  • Nothing other helped. I am using Fedora 30 on a Dell XPS 13 9380 with 3840x2160 display. Add/replace following lines at the end of /opt/google/earth/pro/googleearth cd $script_path; xrandr --dpi 240 LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH LC_NUMERIC=us_US.UTF-8 ./googleearth-bin "$@" – Erich Kuester Sep 7 '19 at 20:45
0
home --> .config --> Google --> GoogleEarthPlus.conf. 

Also set this entry:

[Render]

...

GuiFontFamily=DejaVu Sans

GuiFontSize=12

...

GuiFontWeight=70

in this GoogleEarthPlus.conf

Any changes in this file don't work, but the fonts with Arial work. Does anyone know how to change the font to a readable font, but without to use the fonts like Arial, Times Roman? Use Open Source fonts for example Liberation Serif

Set the a picture in attachment to show you the unreadable font in Google Earth

Hey check out this for more clarification

| improve this answer | |
0

This is fixed by installing windows fonts and one extra package:

sudo apt-get install lsb-core ttf-mscorefonts-installer

Next time you run Google Earth it will look fine.

| improve this answer | |
  • Should be: ttf-mscorefonts-installer – david6 Jun 7 '12 at 22:13
-1

I've found that logging out/rebooting sorts the ugly fonts out.

| improve this answer | |
  • I did logging out and rebooting too. But the problem persists. – Pawan Neupane May 9 '11 at 18:33
-1

What helped me was installing the following packages: xfonts-100dpi xfonts-75dpi

I got the hint from this thread on Ubuntuforums.org: http://ubuntuforums.org/showthread.php?t=1790776

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy