I would like to have an Ubuntu 11.04 64-bit test environment. When I try booting the Ubuntu 11.04 64-bit installation CD in VirtualBox, the following message is displayed by VirtualBox:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

What am I doing wrong?


  • VBox.log, ubuntu-test.vbox, and /proc/cpuinfo.
  • Kernel: Linux aux 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
  • The Virtualization setting in the BIOS is set to Enabled.
  • 6
    Turned out to be a bug in my BIOS. A workaround is available. I'm accepting Chrissss's answer since it should work in most cases. – ændrük May 10 '11 at 3:34

10 Answers 10


In order to be able to run a 64-Bit system in a VirtualBox, you need a cpu which supports virtualization. AMD calls this function AMD-V, Intel uses VT-x. The Wikipedia explains this quite good. There are a couple of Pentium-4 CPUs which are able to run a 64-Bit OS, but don't offer this VT-x technologie. You can check your system by...

$ egrep '(vmx|svm)' /proc/cpuinfo
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx cid cx16 xtpr lahf_lm
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx cid cx16 xtpr lahf_lm

If you don't get any output, you're not able to run a 64-Bit OS as guest inside your VirtualBox. But don't forget to check your BIOS settings. You might be able to activate these AMD-V/VT-x features inside the BIOS of your computer.

And finally there's a checkbox inside the VirtualBox-Settings. Start VirtualBox, select the virtual machine where you want to run your 64-Bit OS and go into the settings of this VM. Look for "Settings -> System -> Acceleration" and make sure that "Enable VT-x/AMD-V" is activated.

  • 1
    Virtual Box does run 64-bit guests on 32-bit hosts when the CPU can handle virtualization and I/O ACPI is set. – Takkat May 9 '11 at 17:58
  • @Takkat, off-topic, but isn't running 64-but guest counter-productive? – Oxwivi May 9 '11 at 18:04
  • 5
    @Oxwivi: not if you need it to test applications :P /offtopic – Takkat May 9 '11 at 18:22
  • 4
    Many BIOSes have bugs related to the enable VT-x/AMD-V setting. That is, they'll say it's on but they'll turn it off randomly (say, after suspend and resume, or subsequent reboots). Check for BIOS upgrades if you have issues. – thomasrutter Apr 27 '12 at 7:12
  • 2
    I can't even access the 'Acceleration' tab, it's greyed out. Guess that means it's at a hardware level? Might look at the BIOS but this is my work computer and don't really want to do that. It's an i5 quad core with 64-bit Windows; strange that it wouldn't be supported when my 2 i5 computers run 64bit vagrant boxes fine. – Kenmore Mar 8 '16 at 14:54

Make sure you've selected the 64-bit version of your Linux distribution in the wizard while creating the guest. I had the same issue, but it was solved by setting correct option at "version" of the distribution.

Even when you boot off a 64bit ISO image, it won't run until I set that option (General -> Basic -> Version).

Then you should have the ability to enable VT-x and I/O Apic.

  • 1
    Interestingly this was the answer that helped me. – Radek Nov 13 '13 at 23:01
  • Gah!!!!! Thank you! VB should totally detect this. – Greg Sheremeta May 23 '14 at 15:53
  • Virtual Box does run 64-bit guests on 32-bit host ? with your solution does it work ? – researcher Jun 1 '14 at 18:58
  • No, 64bit guests requires 64bit host, but a 64bit host can host bot 32bit and 64bit – Mattisdada Sep 29 '14 at 11:17

Enable virtualization in the BIOS.

If it still doesn't work, keep the machine shutdown for a couple of minutes.

  • 1
    I don't understand why I needed to keep the machine shutdown for a while. But it helped. Thx! – lukassteiner May 10 '13 at 15:59

You need to enable the IO APIC to boot a 64 bits OS. At least that is what the docs say, look at the text in the big red square ;).

It doesn't look enabled in your .vbox file:

<IOAPIC enabled="false"/>
  • Thank you, I should have seen this earlier. Sadly, however, enabling this did not change the behavior of the guest OS. I have since learned that there is an "Ubuntu (64 bit)" preset in which this setting is enabled by default, though. I've updated my question with newer information after recreating the VM using this preset. – ændrük May 10 '11 at 2:18

According to VirtualBox you should:

  • upgrade your BIOS if possible
  • remove the KVM modules (Linux host)

3.1.4 will contain a workaround for people with a broken BIOS and no option to update it. Set the VBOX_HWVIRTEX_IGNORE_SVM_IN_USE environment variable to true:


This will tell VirtualBox to ignore VERR_SVM_IN_USE and continue to use AMD-V.
Note that this is a hack and dangerous if you run more than one hypervisor at the same time.


This is an issue only with VirtualBox, to me it is stil a bug. If you install the same OS let's say using the VMWare Player on the same machine it works just fine. Without updatin the BIOS.

Pretty annoying.

  • I noticed it too. I tried VMWare with 64-bit Fedora and 64-bit ubuntu with no issues. But for VirtualBox it seems to only work with the 32-bit. – Archimedes Trajano Dec 1 '13 at 7:34

For an Asus M5A88-M mobo with an AMD FX6100 CPU, the correct BIOS selection is in the 'CPU Configuration' (under the Advanced tab), ENABLE "Secure Virtual Machine Mode" and as already mentioned, make sure VBox "Settings -> System -> Acceleration" and make sure that "Enable VT-x/AMD-V" is activated.

For allowing more than one core with this config you have to unlock the cores in the BIOS (or by pressing 4 at the Asus splash screen), but I haven't tried core unlocker yet.


I got Virtual Box 4.1.12 with the corresponding extension pack installed on Linux Mint 13 Maya Xfce OS and installed Windows XP Home edition in it.

With a little help from my son I now have the USB's activated. To activate the USB's, press the right Ctrl+Home keys and select DeviceInstall Guest Additions, run it, it installs a number of things in Windows, leave the 3d box unchecked.

When it restarts Windows make sure it boots up in Safe Mode, log in as Administrator (Windows) then rerun the Install Guest Additions, this time check the 3D box and when it is all done, reboot the session. Shut down the Windows XP session, close VirtualBox, shut down the computer. Restart the computer, restart virtual box, restart Windows XP session, now press right Ctrl+Home, DeviceUSB should work, you should see any USB devices connected in the drop down.

I was able to connect my TI calculator (which has very limited functionality in Linux (probably more than my knowledge)). Windows XP in VirtualBox on Linux host PC is the way to go with Windows.


if you have the capacity then enabling on your BIOS should be really easy, just boot up into BIOS and look for "Virtualization" it should be under "Security". Then just enable. :)


Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.The Virtualiation setting in the BIOS is set to Enabled.

I had this same problem. I changed the BIOS settings to enable VT-x virtualization on my lenovo. After this the virtual machine said that even though it was enabled, I couldn't use it in my virtual machine. So I ended up deleting my virtual machine and starting a new one in the oracle vm virtualbox GUI. This one had the VT-x enabled in settings/system/acceleration tab under hardware virtualization.

Not the answer you're looking for? Browse other questions tagged or ask your own question.