I just installed Ubuntu 13.10, and I can't configure my wi-fi Epson TX430W printer.

Using the Settings->Printers interface, I can detect the printer. When I click add, I briefly see a "Searching for drivers" dialog. It dissapears, and then I'm left with the printer forever in "Installing" status.

If I close the window and reopen Printers, it doesn't show up on the list.

How can I solve, or at least diagnose the problem?

  • I can't find any information on a TX430W... When and where did you get it? – Seth Feb 4 '14 at 1:05
  • Ah, I found it. It appears to only be sold in Latin America. Epson itself doesn't have an Linux drivers for this particular printer. – Seth Feb 4 '14 at 1:10
  • @Seth thanks, yes, I live in latam. I'm now trying to manually install the generic drivers, without the graphical interface. If this fails, I'll update the post – slezica Feb 4 '14 at 1:11

I opened a terminal and launched system-config-printer, the old configuration interface. I followed the steps until I was presented with 3 driver options for the printer.

system-config-printer dumps data about these drivers to the terminal, in particular the URL for the deb file served by Epson. I manually downloaded and installed the driver.

With the driver pre-installed, the normal configuration process worked perfectly.


For me, the network printer on 13.11 GUI (fresh install) was stuck regardless if I selected the "download driver" (gutenprint) or not. I did sudo apt-get install printer-driver-gutenprint, but it didn't help. A temporary fix: starting


in the terminal and pressing Ctrl+C when the dialog freezes I was able to get through to the next dialog step, where I could see the manual selection list. The recommended setting (generic printer driver) worked fine.

Those problems were not present in the version 10.04.

  • 1
    Mine was just a case of 3rd time lucky. I had to kill the installer the first time, the second time I was asked if I wanted to use gutenprint and it proceeded to do nothing, then finally I selectef gutenprint and it Just Worked™ – Ian Clark Aug 21 '15 at 12:35

Workaround on 15.10: install the driver manually first

# Clean up messy state we were left in.
sudo killall -9 system-config-printer.py
sudo rm /var/cache/debconf/*.dat

# Search for the driver
apt-cache search epson-inkjet-printer | less

The packet description contains the model name. E.g., I have an XP-202, so my package is:

epson-inkjet-printer-201202w - Epson XP-30/102/202/205 Series - Epson Inkjet Printer Driver

The 201202w also shows on the GUI when you get to choose which driver to install.

Now just:

sudo apt-get install epson-inkjet-printer-201202w

And add the printer normally.

Launchpad bug report: https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/1307917

  • Thanks! I opened system-config-printer to see the driver name, instead of using apt-cache search, then manually installed it according to your instructions. – Roberto Dec 1 '15 at 1:12

For people who are getting this issue now, Seiko Epson Corp. has provided a free software (GPL license) printer driver package for Linux that supports a large number of Epson printers. It looks like it supports the TX430 series as well. (https://www.openprinting.org/driver/epson-escpr)

It's available to Ubuntu as printer-driver-escpr.

Step 1: Clean up files so that we can install printer drivers without errors regarding debconf/config.dat being locked. (Thanks Ciro!) $ sudo rm /var/cache/debconf/*dat

Step 2: Install printer-driver-escpr. $ sudo apt-get install printer-driver-escpr

Step 3: Start up your printer utility and select your printer.

Step 4: Choose to install a "Local Driver", select the model closest to your printer, and continue.

You should now be able to use your printer. Verified on LXLE 14.04, derived from Lubuntu/Ubuntu 14.04 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.