I am a noob to linux and could use some help. After much searching and reading I have been able to connect my Toshiba C665-S5177 to the internet. To do so I had to install the Realtek drivers for wireless card rtl8192ce from the Realtek website.

The method of installation followed the ReadMe file include with the driver...

make clean    
sudo su    
make    
make install    
reboot

However, my internet connection is very slow and is continuously dropping and reconnecting.

Advice from some previous posts suggested running the wireless info script. The results from the script are linked here.

The script was run while attached to the internet via ethernet, which works well. If you would like me to run the script again while connected to wireless I can do that.

Late answer but hopefully helps some people...

I have a Thinkpad x121e which uses this driver (rtl8192ce) and when I installed Ubuntu 14.04 I kept having WiFi disconnects, about every 15 minutes.

From a post on the Arch Boards I found a fix. The problem is apparently with powersaving features of the driver, specifically ips (link power save) and fwlps (presumably firmware power save). These are enabled by default.

The fix is to create a file /etc/modprobe.d/rtl8192ce.conf and add this text to it:

options rtl8192ce ips=0 fwlps=0

You will need to be root to do this. Then reboot and hopefully you'll have a stable WiFi connection. (Incidentally I'm using a newer kernel from kernel.org but I don't think that is relevant/important to this fix).

  • Alternatively, you can reload the module instead of a reboot: sudo modprobe -r rtl8192ce; sudo modprobe rtl8192ce Also, it may actually be the kernel as I too had issues with this card on 14.04 until after the first couple of updates came out. – mchid Mar 2 '16 at 21:49

I have a lenovo T430s with drivers rtl8192ce running ubuntu 14.04(lts). Had same exact issues. Pinging a local server on the LAN would return 50ms and every 10 seconds or so it would jump to 1200 even 2000. Every 10 minutes or so, it would just disconnect.

the solution was as suggested by Clockworkz

create /etc/modprobe.d/rtl8192ce.conf and add options rtl8192ce ips=0 fwlps=0 then reboot.

Now pings to same machine are below 10ms.

Have you tried the fix that corrected this issue with the same card?

Realtek RTL8188CE desconects randomly and features slow connections

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.