2

How can I disable a notebooks built-in keyboard - before the login screen.

I have a non functioning built-in keyboard on my notebook. In it's current state it types characters randomly. I am using an external keyboard, and would like to avoid problems logging in

I searched and found some solutions, like scripts - but I need one that works before the login screen.

  • What laptop model? And what solution exactly did you already try? – landroni Feb 10 '14 at 21:46
  • At this moment, i'm using this command xinput set-int-prop 14 "Device Enabled" 8 0 to disable the keyboard. But, I had to type this everytime I turn on my computer. So, i asked a friend of mine about putting this command at the OS initialization. So I did what he said to do (Put the command in the init.d) , and now, i do not have to type the command everytime I turn on the computer. However, only works after the login screen, and after the Terminal opened. – João Mosmann Feb 11 '14 at 3:00
  • I added software-based solution in my answer. – landroni Feb 11 '14 at 7:29
  • 1
    This question appears to be off-topic because it is about a hardware problem. – Mateo Feb 24 '14 at 20:33
  • Can you add your solution a an answer @JoãoMosmann I edited to remove the confusion - so we can focus on how to solve this with Ubuntu - not how to fix the hardware. – Mateo Feb 24 '14 at 22:25
0

Well, I could suggest a hardware-based solution. You could look up the laptop's manual, open it (screwdrivers, etc.), find the connector that links the in-built keyboard and the laptop's motherboard (on my HP dv3 this was relatively easy), and unplug it. Then you won't have any more inadvertent key presses. While you're at it, you could take out the keyboard and see if it's possible to clean it up to make it behave.

As for a software-based solution, you can put xinput set-int-prop 14 "Device Enabled" 8 0 (as per your current workaround) in /etc/rc.local. You need to insert your command in this file before exit 0. For details, see Is it possible to run a command before log in screen?.

-1

It sounds like you have issues whit sticky keys, that prevents you from logging in. (if that's correct then your only option are to remove the keyboard, from your notebook.

Google: How to remove keyboard "REPLACE THIS WHIT YOUR COUPUTER MODELNAME". And follow some guide its fairly simple.In most cases you don't even need to remove screws. go to http://www.aliexpress.com/ and order your self an new keyboard for that computer, and while you wait for it connect a external USB keyboard to the computer, and your able to log in.

You should clarify if you'r able to log into the computer, remote access it whit SSH or VNC. (then it would be easier for others to explain to you what to do.

if your able to log in you can try to open an new terminal type CTRL+ALT+T and type in

sudo nano /boot/grub/grub.cfg

Add

i8042.nokbd 

in the the end of the file, and save the file

CTRL+X (type Y) and enter

and type

sudo update-grub

In the terminal

  • It isn't sticky keys. It is a kind of short-circuit. Actually, I already have a external keyboard and I'm able to login, but with great effort, pressing ALT to prevent the unwanted pressed keys. Deal with hardware isn't an option. – João Mosmann Feb 11 '14 at 2:52
  • I edited my answer, you can try to do that. – BD Bear Feb 11 '14 at 3:00
  • I was sure that I already done that. But I found no i8042.nokbd in this file. I will try it. – João Mosmann Feb 11 '14 at 3:06
  • 4
    The i8042.nokbd shouldn't be added to the end of /boot/grub/grub.cfg file. It would be a syntax error there and will be overwritten as soon as you run sudo update-grub. That string should be added to the /etc/default/grub file, in the GRUB_CMDLINE_LINUX_DEFAULT= line, so that line should read something like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nokbd", then run sudo update-grub. – falconer Feb 11 '14 at 10:58
  • Good point @falconer. I will try your tip, because it didn't work. – João Mosmann Feb 11 '14 at 13:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.