3

I am using Ubuntu 13.10 with gnome-shell 3.10 installed from Ubuntu Gnome "next" repo. The problem I am facing is that when I switch workspaces (ie. using Ctrl-Alt-arrow combination), all windows being currently open on given workspace simply loose focus, actually nothing is focused at the time. I then need to either click on a window or flick with alt-tab to get desired window to gain focus again.

Example:

  • Google Chrome window on workspace 1 has focus
  • switch to workspace 2 (ctrl+alt+down)
  • switch back to workspace 1 (ctrl+alt+up)
  • no window has focus on workspace 1, need to click it or press alt-tab to focus the window

Expected behaviour: The last focused window on given workspace should re-gain focus as soon as I switch back to that workspace.

The "Focus mode" setting in Tweak Tool is set to "Click", however I don't recall having such problem before, ie. with earlier versions of gnome-shell. Changing mode to "Sloppy" or "Mouse" is not an option, as I don't like the idea of mouse cursor driving focus. Also tried to disable all extensions I currently have enabled -- no luck either.

Anyone experiencing similar issue and managed to solve it?

UPDATE

Just ~hour after posting this question I've managed to nail the issue. Turned out to be really really trivial: Google Hangouts extension in Google Chrome has had "Keep Hangouts on top of other windows" option switched on. How lame of me. Well, it's been cool to have Hangouts chats pinned to the notification panel but I finally can have focus working properly again.

  • If you found the answer for yourself, I'd recommend you post it as an answer explaining what exactly happened, how did you identify and what steps you took to overcome... etc. Then mark it as an answer, which may later benefit someone with similar issues. :) – AzkerM Feb 3 '14 at 17:14
  • 1
    You just made my day !!! Thanks for this i was loosing my times looking around compiz settings to find which dawn option could possibly make focus act so strange. Will never have thought to look at this @%#!!! hangout settings! Thanks thanks thanks :) – malko Sep 3 '14 at 23:02
0

Taken from an OP's edit:

Google Chrome's Hangouts extension had its "Keep Hangouts on top of other windows" option switched on. So you'll have to forgo pinning the Hangouts chats to the notification panel to get focus working properly again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.