4

This is a quick post to show how to make wine app hides the titlebar and fully fill the vertical area of screen space when maximized.

In Unity DE, when Wine app is maximized, it doesn't hide the titlebar so the window can't be fully maximized. It looks something like this:

titlebar still showing on maximize

4

The fix is simple. Launch CompizConfig Setting Manager (apt-get install compizconfig-settings-manager) and open Window Decoration setting and in the Decoration Windows field, delete the existing rule any, then enter (!state=maxhorz & !class=wine)

If you got that right, your wine app titlebar should no longer appear when the app is maximized and it will be shown back when you unmaximized it.

Titlebar is hidden on maximize

  • 1
    Just want to note that, since Ubuntu 14.04 the decoration rule that I submitted here has been made redundant as Unity now uses its own window decorator and that seems to have magically solved the issue with wine app window being unable to fully maximize – Flint May 5 '14 at 17:55
0

There is an easier way to do that. Open up your terminal and type winecfg. Then, choose Graphics and disable "Allow the window manager to decorate the windows" option, like so: Disabled "Allow the window manager to decorate the windows"

Finally, click "Apply" and that should be it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.