In trying to install nvidia drivers a number of times I end up corrupting my install of Ubuntu to the point where it won't boot. I end up with the messages:

nvidia: module license 'NVIDIA' taints kernel
Disabling lock debugging due to kernel taint
nvidia: module verification failed: signature and/or required key missing - tainting kernel

Since then reinstalled Ubuntu about four times.

I have only recently managed to get into the login screen for the "UI" (is that called "X"?) from the harddrive. That said I can get to a terminal on my harddrive by doing the following:

  1. Select Advanced from GRUB start-up menu
  2. Select 3.11.0-15-generic recovery mode
  3. Optionally click on network (enable networking) if I want the "dpkg" step to actually update/download/fix anything
  4. Select dpkg (repair broken packages) from recovery menu (to make file-system read/write)
  5. Select root ("drop to root shell prompt")
  6. Now I have a full screen terminal and I can do things like update the /etc/default/grub file

But, I have yet to figure out anything (nomodeset, backlight, etc) which get me past the login screen from the harddrive.

It seems like my problem is 99% likely to be the drivers I have installed, my xorg.conf and the specific graphics card I have (NVIDIA GeForce GTX 780 - 3 GB - 941 GHZ).

One approach I'd like to try is to get my harddrive "config file" to match the USB drive "config file". Unfortunately I would only be able to look at the harddrive "config file" from that same "full screen terminal" - whereas I could use the UI to look at the USB drive start-up config file. I do notice the USB drive uses some argument/parameters to the Linux command like casper and am wondering if I could do similarly when I start from the harddrive. Otherwise I think my next best bet is to try to get the harddrive boot to more closely match the USB drive boot.

For example this is the command for the harddrive call to the command linux:

linux /boot/vmlinuz-3.11.0-15-generic root=UUID=01494fc3-a040-46dd-b8ef-23ce81b59dbe ro quiet splash nomodeset $vt_handoff 

And here is the command for booting from the usb drive:

linux /casper/vmlinuz.efi file=/cdrom/preseed/ubunutu.seed cdrom-detect/try-usb=true noprompt floppy.\allowed_drive_mask=0 ignore_uuid boot=casper quiet splash -- nomodeset

Can I use the "casper" aspect of the USB drive in my boot from the harddrive or should I be looking at some "start-up config file" to see if I can make the hard-drive one match the USB drive one.

One other idea - I do notice when I list the drivers from the terminal/shell on the harddrive using the command: jockey-text -l

I only see the two nvidida drivers (kmod:nvidia_319_updates and kmod:nvidia_319) and never the nouveau video driver. Just to be sure my version of Nouveau was up to date and working on my harddrive - I also just ran this:

sudo apt-get install noveau-firmware xserver-xorg-video-nouveau xsever-xorg-video-nouveau-dbg

It installed - but same thing - I get to the login screen, can see the password field update as I type my password, but as soon as I hit enter the screen goes black.

Also it is worth mentioning I can't boot from the harddrive even using the graphics fail-safe selection from the recovery menu. However, I took a look at this file


and in that file I notice the device driver is set to "vesa". I also noticed I didn't have a xorg.conf - so I created one with a reference to nouveau.

By running the command:

X -configure

a new file /root/xorg.conf.new is generated - so I moved it to /etc/X11 and took a look at it.

It has eight screens configured in it and the screen named "Screen2" shows nouveau. I renamed it to xorg.conf (in the /etc/X11 directory) for the first time (in over 48 hours) I now see a start-up screen loaded off my harddrive!

However, when I enter my password, the screen goes black. One poster showed me you can use ctrl-alt f6 on the login UI (assuming that appears for you) and that gives you the non X (non UI) terminal interface (you can login here). But, even if I do that - I still don't know what to try next. As soon as I login on the login screen appear - the screen just goes black. Presumably this is still related to my graphics set-up - perhaps deleting those seven other entries in my /etc/X11/xorg.conf file?

After trying to improve the situation by doing things like installing bumblebee - the login screen stopped appearing.

One thing that might be worth mentioning is if I list all my drivers using

jockey-text -l
I see

kmod:nvidia_319_updates (proprietary, disabled, not in use)
kmod:nvidia_319 (proprietary, disabled, not in use)

When I installed bumblebee it added this entry

kmod:nvidia_304 (proprietary, enabled, not in use)

The reason they're all marked "not in use" is because I got to this terminal through the recovery mode menu.

I then purged/removed the nvidia_304 driver using this page: Disabling restricted graphics drivers not listed by jockey-text

Specifically this bit

sudo apt-get remove --purge nvidia-*

When I ran the desktop command - it was already installed and at latest.

So now I can get back to the login screen - but it still goes black when I login and something else I just noticed is that the UI stops responding/updating if I move the mouse.

More shooting in the dark - when I ran this command:

dpkg -l | grep -i nvidia*

I noticed the primus and bumblebee drivers were still installed/resident on my machine in addition to the following:

bbswitch-dkms amd64
nouveau-firmware all

So I used the following command:

sudo apt-get remove --purge bumblebee

Which uninstalled both bumblebee and primus. That didn't make things any worse - I was still able to reach the login screen and type my password - but again after entering my password - the screen goes black and I'm forced to restart.

Any other suggestions?


  • I've definitely searched for the same graphic card problems - but I suspect I'm just not looking at the right posts. I think my chrome history would show I've read over 100 posts on Ubuntu graphics issues (mostly on this forum). As for your other questions - I'm lead to believe that I'm better to install from repository (if for no other reason than exercising the non-proprietary drivers is useful to the developers of Ubuntu). However, it seems like I get closer to "things working" using the UI off the harddrive when I get the system to use nouveau. Any suggestions? – user242289 Feb 2 '14 at 19:06
  • sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx libegl1-mesa-drivers , reboot then try . if does not work try again with ctrl+alt+f6 sudo service lightdm stop ; sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old-nv ; sudo dpkg-reconfigure xserver-xorg, reboot – user.dz Feb 2 '14 at 19:48
  • What do you mean about ctrl+alt+f6? Do you mean after I login? After login I'm immediately taken to a black screen. The only way I've found to execute any commands on the harddrive is to go into diagnostics mode, enable networking, use dpkg to make harddrive read/write and then drop to root. Can I execute the service lightdm command from there? Or does that require me to have "X" running? – user242289 Feb 2 '14 at 21:43
  • Ah - you can enter ctrl+alt+f6 at login and it just switches to a terminal screen - good to know. Previously I was executing all commands on the harddrive by going into diagnostics mode, enable networking, use dpkg to make harddrive read/write and then drop to root. – user242289 Feb 2 '14 at 21:50
  • It found it - sorry I asked before I tried it - I just wanted to ensure I did it right. That first "apt-get install" command you gave me ran without issue, I restarted and no difference. I tried the second command you gave me and when I ran it (or actually the three different commands followed by the reboot command) - when I restarted the UI didn't load up, black screen with a little cursor up in the top left corner of the screen. I'm going to try restoring the xorg.conf and see if I get back to the login UI again. I appreciate the help though - I really don't know what to try next. – user242289 Feb 2 '14 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.