Old title : Wireless connected, but no internet until I re-add network

Every time I boot my Laptop, it doesn't connect to Internet.

Although upon boot it does say "Connected to ", but when I try to browse any webpage, it doesn't load. So everytime upon boot, I have to go to the Network manager -> remove the wireless network -> then again add the Wireless network, to find that Internet is connected finally.

I also use my Desktop, which with the same settings, does get connected to the Internet without any issues.

Please note that I am connected to the Broadband modem via a Wireless router and the Wireless network SSID is hidden for presumably higher security. Please help to solve this issue.

EDIT 1 : I have now unchecked the Hidden option of the SSID to make it a broadcast SSID. So its's no longer hidden now. But still the problem persists.

EDIT 2 : In search of a solution, I have now started using the indicator-network applet, which has installed connMan. Now the problem is everytime upon boot/reboot, I have to type in the wireless network name and security from the others option and press connect. Then it gets connected.

It would be very helpful, if connman can automatically detect my already added wireless network. Does anyone help me with a suggestion on how this can be done?

  • @Oxwivi: Thanks for your quick response. I have tried the "Available to all users" option. But still the above problem persists. Do you think that this has anything to do with the hidden network? May be a hidden SSID is the cause, but I am not sure about it.
    – Arindom
    May 9 '11 at 6:44
  • Okay, I think I'm wrong to say it's a duplicate. Is the desktop connected to the wireless or wired?
    – Oxwivi
    May 9 '11 at 7:02
  • And edit your question to something like "Wireless connected, but no internet until I re-add network".
    – Oxwivi
    May 9 '11 at 7:02
  • @Oxwivi: I missed your first question. That is why I was wondering why no response is coming. It's my mistake. The Desktop is connected wirelessly and it is also on Natty.
    – Arindom
    May 10 '11 at 4:11
  • I apologize - I myself am too inexperienced and lacking in knowledge to help you any more.
    – Oxwivi
    May 10 '11 at 5:32

Its worth trying alternative network managers such as the standard Gnome Network Manager or WiCD - both of which are available in the software centre application.

Assuming you try WiCD, you will find that there is no application indicator to directly control the application.

However, you could create a desktop launcher (right click the desktop) and type in the command

wicd-client -n

You could then drag that launcher into the main Icon Dock on the left-hand side of the screen.

Alternatively you could try whitelisting the WiCD application itself so that it could be controlled from its "app indicator" icon in the top-panel as per the AU question and answer:

n.b. I recommend using the dconf-editor answer not the "all" answer

  • @fossfreedom : Many thanks for your excellent guidance. As recommended by you, I tried the dconf-editor. I now have the wicd icon on the Natty panel. Also, it seems the original problem of no network upon boot (when both system and router is restarted), is solved now. Except that the connection dropped and restarted automatically a couple of times, there is no other problem. If this issue persists, I will report it here again.
    – Arindom
    May 14 '11 at 10:23
  • @fossfreedom: I have one more question here. I have a pptp VPN connection which I need to use at times. As because there seems to be no option of graphically connecting via VPN, I had to install the Network Manager. My question is, whether there is any way to connect to the VPN with WiCD? If yes then I guess I can remove network manager because that might be causing the initial disconnection of the wireless network.
    – Arindom
    May 14 '11 at 10:25
  • @fossfreedom: Thanks for your help. This seems to solve the long standing problem of adding the network everytime I boot both my PC and router. I now have one more problem of Internet getting disconnected when using VPN. I want to access both VPN and public sites. In this regard I have a detail question here : askubuntu.com/questions/39894/… . May I request you to please look at the above thread and if possible suggest a solution.
    – Arindom
    May 14 '11 at 10:28
  • ok - will look at that issue and will reply if I have any ideas - however, as you might have guessed, its not wise to run both network manager and wicd - they will be both competing to do the same stuff - hence could possible cause issues such as disconnections.
    – fossfreedom
    May 14 '11 at 10:32
  • Thanks fossfreedom. I want to remove the network manager since I have wicd. But how do I connect to my VPN connection? There seems to be no option of getting connected to an existing VPN connection.
    – Arindom
    May 14 '11 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.