1

So I'm trying to get custom shells and have tried using this as many people have recommended it. All I see in the Shell Extensions menu is "install shell extension" and when I click on the link user themes isn't there. Also, in the theme menu, there is a triangle with an exclamation mark in it next to Shell Theme. how can I fix this and get shell themes like Faience?

  • Did you update your version of gnome? Some extensions are only compatible with some version of Gnome. – Wilf Feb 1 '14 at 23:58
  • how do i do that? – user242628 Feb 2 '14 at 0:20
  • yes i just looked and i do. ubuntu had some weird icon and said i had to remove some files update some files and replace some, so i did and the stuff in the shell extensions went away hence why i change my question – user242628 Feb 2 '14 at 0:51
1

To get a user specified shell theme, use this extension:
User Themes - GNOME Shell Extensions. Install it from the extension, page and make sure it is on in gnome-tweak-tool: enter image description here

and here are the results - with it off, and with it on: enter image description here

You can then use gnome-tweak-tool, or dconf-tools (use org.gnome.shell.extensions.user-theme name NAME_OF_THEME) to set the theme - here is Gnome Tweak Tool again:

enter image description here

By the way, I recommend the Zukiwi Theme - you may be able to install that with:

sudo apt-get install zukiwi

For your original question, as this is useful also for reference:

To fix some shell extension that also have the warning triangle, particularly after an update:

First, go to here, and see if any update icons are displayed.

If that does not work, first find your version of Gnome by running this:

 gnome-shell --version

In my case, this is 3.10.3, but I only need the 3.10 bit.

Then open Nautilus (File Manager), open the location bar (Ctrl+L), and enter this:

~/.local/share/gnome-shell/extensions

Alternately, view hidden file with Ctrl+H, and open .local > share > etc

Find the folder with the extension in - For instance, Status are Horizontal Spacing, by mathematicalcoffee, is in this folder:

status-area-horizontal-spacing@mathematical.coffee.gmail.com

Open up the folder, then open the file metadata.json. Find these lines:

  "shell-version": [
    "3.4", 
    "3.6", 
    "3.8"
  ],

and add your version of Gnome in if it is not present:

  "shell-version": [
    "3.4", 
    "3.6", 
    "3.8",
    "3.10"
  ],

Note where you need the commas ,. Save and exit, and after reloading the shell (Alt+F2, enter r, and press Enter), the extension should work. If the warning triangle is still there, then it is probably some other problem.

  • So i clicked the link for the user themes and clicked the switch to on and clicked install when it asked me but nothing happens after that.... what do i do now. – user242628 Feb 2 '14 at 19:05
  • Close the browser window, and reload the page - the switch should hopefully still be on to indicate it is working. You should now be able to enable the theme in gnome-tweak-tool. To work, theme be gnome-shell compatible, and in /usr/share/themes – Wilf Feb 2 '14 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.