I recently upgraded from Ubuntu 12.04 to 13.10. I have a AMD Radeon HD 4870 Graphics Card. On 12.04 I used AMD Proprietary drivers from their website and had no problems but since switching to 13.10 when I tried to install the Drivers it says that there are fglrx tools missing that need to be there for install. I tried using apt-get to install fglrx, and when the download finished I rebooted my PC and said that the graphics drivers were no good and I had to reinstall 13.10. So I can't just apt-get the fglrx drivers like I have done previously. Does anyone have a solution and does anyone else have this issue? I would like to have the Catalyst Control Centre but that comes with the proprietary drivers not with the radeon open source drivers. I also use a 32 bit system if that helps. Thanks


I do not think that AMD is supporting the 2xxx,3xxx,and 4xxx cards anymore. There are legacy drivers for them, but they do not work for the newer kernels after 12.04. There is a work around for them but from what I read, it is a 50/50 chance of it working, and you probably have to rework it after system updates. It might break your system also, use at your own risk. I think your best bet would be to use the open source drivers, unless you must have the Radeon drivers for your system, you could reinstall 12.04. Colin

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.