4

This question already has an answer here:

Basically, no sound is coming out the television. I'm running out of idea of why?

Viewing the PulseAudio control panel, it's putting sound out the HDMI

enter image description here

Alsamixer is not mute

enter image description here

The Television is not mute. I booted into Windows and the audio out the HDMI works fine.

enter image description here

Debugging Info:

Basics

  • Xubuntu 13.10
  • Linux desktop 3.11.0-15-generic #25-Ubuntu SMP
  • ATI 4870

lshw -c video

   description: VGA compatible controller
   product: RV770 [Radeon HD 4870]
   vendor: Advanced Micro Devices, Inc. [AMD/ATI]
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=radeon latency=0
   resources: irq:44 memory:d0000000-dfffffff memory:feae0000-feaeffff ioport:c000(size=256) memory:feac0000-feadffff

aplay -l

   **** List of PLAYBACK Hardware Devices ****
   card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
     Subdevices: 0/1
     Subdevice #0: subdevice #0
   card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
     Subdevices: 0/1
     Subdevice #0: subdevice #0

sudo speaker-test -c 2 -r 48000 -D hw:1,3

   speaker-test 1.0.27.1

   Playback device is hw:1,3
   Stream parameters are 48000Hz, S16_LE, 2 channels
   Using 16 octaves of pink noise
   Playback open error: -16,Device or resource busy

marked as duplicate by Takkat, falconer, Eric Carvalho, karel, Avinash Raj Feb 2 '14 at 4:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    In case you use the open source radeon driver you may need to enable HDMI audio with a Grub setting: askubuntu.com/questions/67113/… – Takkat Feb 1 '14 at 18:52
  • @Takkat that worked perfectly. Thank you very much – Andrew Wei Feb 1 '14 at 19:01
  • 1
    Glad you got it running :) +1 for the extremely well written question, but we probably have to close it as a dupe to the question I linked to. – Takkat Feb 1 '14 at 19:05