I'm trying to install Ubuntu 12.04.3 on a new Laptop which came without any OS. (except free DOS). The Laptop is a Lenovo Ideapad Z 510 with these specs:

  • CPU: Intel Core i5-4200M, 2x 2.50GHz
  • RAM: 8GB (1x 8GB)
  • Harddisk: 500GB SSHD (8GB SSD-Cache)
  • Drive: DVD+/-RW DL
  • Graphic card: NVIDIA GeForce GT 740M, 2GB, HDMI
  • OS: FreeDOS


Shortly after the insallation of Ubuntu starts, the Screen goes completely blank/black. The display is off, there is not back light at all.


While the display remains off, I can - at some point - hear that familiar Ubuntu percussion-kind-of drums notification. AND occasionally, when I try to plug in an external monitor, I can - on the external screen - see the familiar Ubuntu background (that redish-violet-organge thing), but nothing happens at all. When I, at some point, e.g. press the space-bar, 'enter' or 'esc' keys, I can hear that sometimes something is reacting to that (DVD-drive 'roars' or flashdrive changes blinking pattern). But it does not go any further than this.

This is WHAT I HAVE TRIED so far:

I used USB drives with these different versions:

  • Ubuntu 12.04.3 LTS (64 bit-version 'ubuntu-12.04.3-desktop-amd64.iso')

  • Ubuntu 12.04.3 LTS (32 bit-version 'ubuntu-12.04.3-desktop-i386.iso')

  • Ubuntu 12.10 (32 bit version 'ubuntu-12.10-desktop-i386.iso')

I used an image-dvd made from the 64 bit-version 'ubuntu-12.04.3-desktop-amd64.iso' on a flatmate's Windows-machine.

THERE ARE TWO WAYS I have gone about the installation attempts:

Number ONE is:

I opened BIOS and chose from the boot-sequencer to boot from USB or DVD-drive respectively. This strategy led me to the familiar screen with a tiny keyboard and a tiny human in a cricle at the bottom of the screen. Then the screen went empty with a cursor blinking at the top-left corner before going completely dark/back/blank/without-any-light.

Number TWO is:

I left the BIOS and boot-sequencer as it was, just took care that the USB flashsdrive was plugged in (or DVD in the drive). Then I always got this screen that is titled: "GNU GRUB version 1.99-21ubuntu3.10". Underneath this title, there's this frame that contais the 3 options:

  • Try ubuntu without installing

  • Install Ubuntu

  • Check disc for defects

Whichever of the three above option I go for, the screen first goes grey/back lit and then completely dark/back/blank/without-any-light - as if it was switched off.

If I don't choose any of these options but hit the 'esc'-key, I always come to a screen that is also titled "GNU GRUB version 1.99-21ubuntu3.10". BUT underneath there's no frame or anything. It simply says:

"Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions. grub> _"

This is all and as detailed I can tell it.

After the rearch I've done so far, I assume it has to do with the graphic card. Apparently there have been similar issues in the past however, they all had an existing OS (Ubuntu or Windows) installed while dealing with booting-issues. However, I can't istall Ubuntu.

Any help is very much appreciated! Thank you!


This is a new Haswell system. They generally only work with the newest 64 bit versions of Ubuntu as the hardware is very new. Linux takes 6 months or more to catch up with new hardware as vendors do not directly support Linux. Intel has been good about updating, but those updates are only in 13.10 and should be in 12.04.4 that will be out shortly. Or even better 14.04 in April.

Do you have dual video or just nVidia. And then which video is it booting with. If nVidia you need nomodeset, but Intel often needs other settings.

Shows install with screen shots for both BIOS & UEFI, so you know which you are using. Your system will boot in either mode. https://help.ubuntu.com/community/UEFI

Lenovo Community Bios Access http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/z580-can-t-access-bios-setup-or-boot-menu-after-changing-to/td-p/812737/page/2

  • Thanks a million! Problem solved. Regarding the nVidia part, I think is's only nVidia. I don't quite know how I made it work, there are two possibilities: NUMBER ONE: Im BIOS, I chose the "set to optimum default values" option, while I had the live-flashdrive plugged in. it set all the necessary options to UEFI and, thus, booted and installed in UEFI mode. NUMBER TWO, it might have been the simple fact that I tweaked the screen brightness button on the keyboard. If this ONLY was the trick, - and luckily I can't determine that - I'd be a little depressed. Thanks to Oldfred, nevertheless! – Mat Feb 3 '14 at 13:54

I had the same problem/identical symptoms with the little brother (Z510, Core i5, 4GB).

The BRIGHTNESS BUTTON did the trick! I don't know whether to cry or to laugh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.