1

Background:

Initially, I created a small partition on a hard drive to try Ubuntu as an alternative to the previously installed Windows XP. After finding Ubuntu useful and running into space problems on that small partition, I created a new bigger one next to it and installed Ubuntu (same version) there again. The boot menu was updated correctly after both installations but since I didn't need the smaller Ubuntu partition any more, I deleted it - leading to a boot menu entry pointing to a non-existent installation. After learning about Grub Customizer, I was able to delete (or hide, whatever) the boot menu entry of the old Ubuntu installation and set the new one as default, everything was fine.

Problem:

After I received an update today (kernel image or something, not sure how to find out what it was exactly), suddenly the old boot menu entries are back at system boot:

boot menu screenshot

An interesting detail is that since the update, the top two entries show the new kernel version 3.8.0-35-generic, even though the entry for the "current" (existent) Ubuntu installation (under which I received the update) is the 6th from the top, i.e. the one on /dev/sdb7, which still shows 3.8.0-29-generic.

The Grub Customizer still showed the menu the way I had configured it previously (removed 2 top entries pointing to the old Ubuntu installation as well as the "Previous Linux versions" entry):

Grub Customizer screenshot

I already tried running update-grub as found here, but this still seems to find the old (3.8.0-29-generic) version, although I am unsure if they are really reported correctly:

friendfx@Laptop:~$ sudo update-grub
[sudo] password for friendfx: 
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.8.0-35-generic
Found initrd image: /boot/initrd.img-3.8.0-35-generic
Found linux image: /boot/vmlinuz-3.8.0-29-generic
Found initrd image: /boot/initrd.img-3.8.0-29-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sdb2
done

...and, more importantly, after rebooting the menu at system boot is still the same, i.e. with the old and "Previous Linux versions" entries.

Question:

What can I do to get the configuration I set in Grub Customizer to apply to the actual boot menu at system start? Did I miss anything obvious?

1
grub-install --boot-directory=/boot /dev/sda
  • 1
    I am always a little scared by something like this... how can I check what /dev/sda really is before modifying it somehow? Ah, got an idea: I can use the Disk Utility program. I'll give it a go and let you know, thanks in the meanwhile... – FriendFX Feb 1 '14 at 12:58
  • It worked, accepted your answer. If you care, could you also explain why it worked and I had to use it instead of update-grub? What's the difference? Thanks again! – FriendFX Feb 1 '14 at 13:07
  • update-grub updates grub configuration in /boot/grub directory. so everything is kind of set. but the grub in MBR is not aware of this. had the same problem. i guess grub-install /dev/sda rewrites stuff in MBR so grub loader is aware of new configuration. i cannot explain it in more technical terms. – anonymous Feb 1 '14 at 13:14
  • That's good enough for me :) ...upvoted your answer. – FriendFX Feb 1 '14 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.