First, I know this may be just an issue with Windows, but I guess people on the Ubuntu/Linux side may know this kind of issue better.

I just did a full system reinstall with new partitioning. I first wiped the disk during Windows XP install and gave 20GB to XP, the remaining space unpartitioned. Later I installed Ubuntu 11.04 and did some more partitioning: 145 GB unpartitioned (it had no NTFS support during installation), 15GB for root, 64GB for /home and 5GB for swap (all of these are an extended partition.

Under Ubuntu, used Disk Utility to format the 145GB as two NTFS partitions. Everything is nice on the Linux side, and I keep both NTFS partitions as shared data location.

I just went back to Windows to try some stuff, and found out that it does not see the two NTFS partitions at all. I found a post of people with the similar issue, but they have no "solution".

What can I do to make XP "see" my partitions? Is it some compatibility issue?


Edit: ok, I guess I found the reason. The NTFS partitions on Disk Utility say "Type: NTFS", but Partition Type: Linux (0x83). Edit Partition button let me change the type, which I suppose should be HPFS/NTFS (0x07). I tried to change it, but then I get a spinning progress bar indicator that never disappears. I tried it also with unmounted partition and with sudo, but it never finishes the job. Every time I tried something I had to restart the system, but at least my partition is ok and usable (or so it seems).

So, if this is the culprit, how can I fix this partition type? Thanks again!

  • 1
    I believe you have to go: My Computer > Manage > Disk Management. You should see the partitions there. Right-click on the partitions you're seeing here, but not elsewhere, and 'Initialize Disk'. I think that should do the trick but the memory's a bit hazy.
    – boehj
    May 9, 2011 at 1:35
  • @boehj Thanks for the tip, boehj. Your directions may be a little off, but I got to the disk properties, where I can "refresh" and "see" all the partitions (including the ext4 ones), but I can nothing to them, and only my primary partition (the one with Windows) have a drive letter and can show me its properties. Still, see my updated topic info above, the partition type seems wrong and I can't fix it. Thanks.
    – mdrg
    May 9, 2011 at 3:28

1 Answer 1


Yes, the partition type needs to be 0x07. Run sudo fdisk /dev/sda and use the t command to tag the partition with the correct code, then w to save and exit.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.