Apparently I need to accrue 10 reputation to post more than 2 links - so reposted everything I learned in trying to install Ubuntu onto my Windows 8 machine with a new graphics card on my blog: http://patientprogrammer.blogspot.ca/2014/01/eight-hours-to-start-ubuntu.html

The summary is - for the first eight hours or so I couldn't get Ubuntu boot-up/load from the USB drive. It would simply end up on a black screen and make the drum noise and the cursor keys would actually generate other noises - so it seems as if it is a graphics card issue. However, after adding the nomodeset flag/setting at the end of the linux line Ubuntu finally loaded off the USB drive - but only version 13 (13.10) - I couldn't get 12 (12.04.3) to work.

My graphics card is: "NVIDIA GeForce GTX 780 - 3 GB - 941 GHZ".

Now for my question - since I was able to work-around this issue using the nomodeset when booting off the USB drive - it does imply/confirm the problem is Ubuntu's "understanding" of my video-card. I'm still unable to load Ubuntu off my harddrive, even if I append the nomodeset flag/setting in the /etc/default/grub file onto this line:


thus changing it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

I've tried running boot-repair three times now. When I boot using the Ubuntu ISO on my USB drive - there are three video drivers listed (under "additional drivers" in "software and updates"):

  • NVidia 319 (proprietary)
  • Nvidia 319 (proprietary, tested)
  • x.org x server - nouveau display driver from xserver-xorg-video-nouveau

And even if I change the above selection (in the UI) to one of the NVidia drivers - when I reboot it returns to the Ubuntu's Nouveau video driver I've read some articles about bumblebee or nvidia-prime. Apparently they're different routes you can go to try to address this - but it requires a series of commands of purge, followed by install, followed by update and I don't want to mess things up worse than they already are - so I wanted to make sure I selected the right drivers/versions and most importantly used the correct commands for my version of the graphics card.

One thing I'm not clear on is when I boot from USB drive and load into the "live session" (I believe that is what it is called) - are the updates I make getting applied to my computer's harddrive or just to the USB drive? The reason I ask is because after issuing a bunch of commands/code like the ones below - a bunch of updates seem to happen and if I load the "Additional Drivers" panel in "Software and Updates" I see a new entry nvidia-331 (open source) has replaced the entry that was once nvidia-319 (proprietary and tested). But then when I restart it is gone again.

I've tried the following commands: sudo apt-get remove --purge nvidia-319-updates sudo apt-get remove --purge nvidia-settings-319-updates

It always just says "not found".

Then the following:

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
#sudo apt-get install nvidia-331
#But instead of the above command - I used
sudo apt-get install nvidia-current

#I've also tried this
sudo apt-get install noveau-firmware xserver-xorg-video-nouveau xsever-xorg-video-nouveau-dbg

But I just get "unable to locate package nouveau-firmware"

I also tried the instructions mentioned in the comments (the BinaryDriverHowto/Nvidia):

jockey-text --help
jockey-text -l
jockey-text -e xorg:nvidia_current

I saw my two disabled nvidia drivers 319 (proprietary and "proprietary and tested") when I used the "jockey-text -l" command. However, when I tried to use the "jockey-text -e xorg:nvidia_current" - it just told me it wasn't found. So off to google I went and found this page: http://falkvinge.net/2013/02/15/how-to-install-nvidia-drivers-in-ubuntu-12-10-quantal/

And I did everything except

apt-get install linux-headers-generic
apt-get dist-upgrade

Because the idea of building the headers and having that "up to date" version of things scared me. But when I used this command

apt-get install nvidia-current-updates

it did end up getting the nvidia_304 driver. And then when I executed this command:


I got something interesting back: "warning: unable to locate/open x configuration file." and "new x configuration file written to '/etc/X11/xorg.conf'"

I don't know if that is a good thing or not - but it sounds like it has now created I file I had needed. And now when I use the "jockey-text -l" command I see a new driver (nvidia_304) and it is "enabled" - but "not in use" (possibly because I'm in the "drop to root terminal").

On reboot - I get

[1.457572][drm:drm_pci_agp_init] *ERROR* Cannot initialize the  agpart module.
[1.457642]DRM: Fill_in_dev failed.

And even if I try going to "recovery mode" it stops/fails here: [1.420000] microcode: Microcode Update Driver: v2.00 , Peter Oruba

and nothing more is printed to screen - so looks like I've bricked it. I can't even access the install of Ubuntu on my harddrive. Back to the drawing board. Thankfully on my PC there is a Ubuntu using Linux 3.11.0-15-generic and Linux 3.11.0-12-generic. Without being able to get into the 3.11.0-12-generic I wouldn't have been able to go into the "reovery mode" menu and "update grub bootloader" and get the windows partition to appear in the grub menu (every time I run boot-repair it removes that entry). I've apparently installed tainted NVidia drivers (according to some error messages when I try to boot into the 3.11.00-15 version) - so that OS can no longer boot - I can't even enter the recovery mode menu to "drop to root" (the terminal window). How hard is it to just reinstall Ubuntu over an existing install using the USB drive? The boot-repair didn't fix anything.

I'm still just taking wild shots in the dark and I'm now 48 hours without a working install of Ubuntu on my harddrive.


  • You need nomodeset to boot live installer and on first boot after install. Then once booted into a low video mode install the nVidia drivers. What system is this and is it an Ultrabook as that may have dual video & extra issues. – oldfred Jan 31 '14 at 23:44
  • When I added the nomodeset to the /etc/default/grub file and updated grub (using sudo update-grub) - I can then see nomodeset when I edit the four different ways I can load Ubuntu - but when I try to load Ubuntu from the harddrive (even with that nomodeset on the linux line) - it still doesn't load. I'm not sure why it only seems to work when I'm booting from the USB Drive. There is actually another post online that had similar symptoms - this guy: bbs.archlinux.org/viewtopic.php?id=157371 – user242289 Feb 1 '14 at 17:18
  • best not to add nomodeset to /etc/default/grub as you only need it until you add the nVidia drivers. You can just edit grub menu as you boot with e for edit and manually add nomodeset. Usually best to just install nVidia driver from repository. But if you already installed from nVidia you will have conflicts. The ppa version will have to be updated with every kernel update as that is not automatic, where repository install is automatic. – oldfred Feb 1 '14 at 18:01
  • I didn't know about the distinction of getting it from "repository" and from "nvidia" (which I guess is the ppa version?). If there was a way to purge the nvidia drivers (ppa version?) from my harddrive and switch to the repository version - I would happily do so. At present I think I'm only updating the harddrive install of Ubuntu when I go into "recovery mode" and "drop to root" (which gives me a full screen terminal). That was how i made the update to the /etc/default/grub file. I've tried executing those driver commands from there - but I think I didn't have a network connection. – user242289 Feb 1 '14 at 18:07
  • Did you get the updates from the ppa? If so you have to totally purge all nVidia before installing from repository. And you have to remove ppa. help.ubuntu.com/community/BinaryDriverHowto/Nvidia and help.ubuntu.com/community/NvidiaManual – oldfred Feb 1 '14 at 18:28

In some cases if a brand new install, it can be quicker just to reinstall.

only reason to purge is there are several versions, if you know you have different nVidia use that: To see available versions:

dpkg -l | grep -i nvidia*

see details for version installed, change from example with 319 to yours.

sudo apt-cache policy nvidia*
sudo apt-cache policy nvidia-319-updates 

sudo apt-cache search nvidia-sett*

Houseclean out all old versions to avoid issues

sudo apt-get remove --purge < nvidiadriverpackagename>

[ using the correct names] for each driver, before running:

sudo apt-get purge nvidia*
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

then you need to reinstall nvidia from repository. Usually you can boot into low resolution gui with nomodeset. Or if at command line.

Install version you prefer I used nvidia-current-updates & nvidia-settings-updates, example below is just nvidia-current, I usually install from gui & system settings, but have used command line.

sudo apt-get install nvidia-current
sudo apt-get install nvidia-settings
sudo dpkg-reconfigure nvidia-current
sudo nvidia-xconfig
sudo reboot

May want nvidia-current, nvidia-current-updates or nvidia-current-experimental-XXX for most recent testing version. Available list is in first command above.

  • If "live boot" (boot from the Ubuntu ISO on my USB drive) and I execute commands like the ones above - does that update the install on my harddrive? Because it seems like when I make updates in that "scenario" - the updates are gone after a reboot. The exception being when I run the boot-repair mentioned here: help.ubuntu.com/community/Boot-Repair I just tried a reinstall - but of the four options: 1.[Reinstall Ubuntu 13.10] 2.[install ubuntu 13.10 alongside ubuntu 13.10] 3.[erase ubuntu 13.10 and reinstall] 4.[something else] I selected (1) - going to try selecting (3). btw thanks – user242289 Feb 2 '14 at 0:44
  • After trying those steps I can no longer boot into diagnostics mode - I get the following errors: [nvidia: module license 'NVIDIA' taints kernel] [Disabling lock debugging due to kernel taint] [nvidia: module verification failed: signature and/or required key missing - tainting kernel] Think I'm about to give up on this... seems like there is something fundamentally broken about the version of Ubuntu I'm using and my very new graphics card. If I were a bit more Linux/Ubuntu savvy - I'm sure I could figure out the correct series of purge, install, etc commands to fix this. – user242289 Feb 2 '14 at 4:56
  • I wonder if some of my problems are that I've never successfully booted off the harddrive into ubuntu? Looking at the commands for the 3.11.0-15-generic - I see the following line linux /boot/vmlinuz-3.11.0-15-generic root=UUID=01494fc3-a040-46dd-b8ef-23ce81b59dbe ro quiet splash $vt_handoff I'm wondering why the nomodeset trick doesn't work when trying to boot off disk? – user242289 Feb 2 '14 at 7:16
  • Reread this post: bbs.archlinux.org/viewtopic.php?id=157371 specifically in my bios - the "boot mode selection" is set to "uefi and legacy" - but even if I switch it to "legacy" - I still don't get Ubuntu to boot off of my hard-drive with the nomodeset parameter in the linux command. Which makes me wonder if perhaps my problem is something else. I also have my /home mounted on a second HD - could it be that? My / mount is on a primary partition on my SSD. My swap is on the second HD as well. I still feel this is a graphics card issue - but I've no idea how to narrow this down. – user242289 Feb 2 '14 at 8:09
  • I already posted the command used to boot off my hard-drive. Here is the command to boot off the USB drive that works linux /casper/vmlinuz.efi file=/cdrom/preseed/ubunutu.seed cdrom-detect/try-usb=true noprompt floppy.\allowed_drive_mask=0 ignore_uuid boot=casper quiet splash -- nomodeset I don't know enough about the linux command to even make a guess. Obviously in the case of the usb-drive it is using this casper thing. And in the case of the hard-drive it looks like it might loading settings from a config file "vmlinux..". Perhaps I should try updating that config file? – user242289 Feb 2 '14 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.