93

I have recently been trying to install VirtualBox, when this message came up:

No bootable medium found!

Can somebody please tell me what went wrong?

4
  • Check to make sure that you selected Linux and Ubuntu when you're creating the virtual machine. I chose Windows and it gave me this exact error. Oct 2 '17 at 1:34
  • 6
    I was so happy to see this message when I first ran VirtualBox. I thought "wow, that really is like a real-world computer!"
    – user334639
    Oct 12 '17 at 0:05
  • 1
    I had to enable EFI on system motherboard tab for windows to work from a VHD.
    – Lanklaas
    Jun 28 '18 at 6:58
  • This may seem obvious, but VirtualBox doesn't come with ready-to-use VM images. Selecting Ubuntu when creating a new VM doesn't install it on VHD. You have to get installation disk and install the OS yourself.
    – user502144
    Aug 12 '20 at 11:53
77

This message simply means that you haven't told your virtual machine where to find its OS.

In the Virtual Machine window, go to Storage, and medium. see image below.

enter image description here

5
  • 3
    It also gives the same error if you have specified the ISO or boot disk like this but it's an inappropriate one - for example I had this problem even after doing everything suggested here because by mistake I'd selected ubuntu-16.04.3-server-arm64.iso instead of ubuntu-16.04.3-server-amd64.iso (I should have used the amd64 version not the arm64 version) Jan 2 '18 at 19:19
  • 2
    This error still appears. Something is wrong on the device itself.
    – neverMind9
    Aug 19 '18 at 22:34
  • I see "Optical Drive" rather than "CD/DVD Drive", and it's disabled - what should I do? Aug 26 '19 at 16:08
  • Do you have guest addtions installed?
    – Mitch
    Aug 26 '19 at 19:32
  • In my case, this setting was correct. But, I was trying to install guest additions while Ubuntu was getting installed. That is why it was messed up. Jul 28 '20 at 20:51
14

I had this problem when I was trying to get my own VM up and running. I had downloaded a VDI file off of OSBoxes and was attempting to use that to create a VM.

When you create your own VM, make sure that, when prompted for the creation of a Virtual Hard Disk, you select:

Use an existing virtual hard disk file

Use the file picker to locate the VDI file in your file system and select it.

Be sure not to create a new virtual hard disk; load the one you are trying to run.

The picture below illustrates my point.

Use an existing virtual hard disk file

9

Assuming you had created a virtual hard drive, and installed Ubuntu onto this drive as depicted in answers to the following question:

Then if you finished you installation, and removed your installation ISO from the virtual CD bay you should be able to boot from this hard drive.

This of course can only be done in case you had included this drive's image in the virtual box machine's "Storage" settings where you can attach the VDI image of your installation to either a virtual IDE, or a virtual SATA port:

enter image description here

In addition we need to make sure you had not disabled booting from your hard drive in the System > Boot Order settings of your virtual machine:

enter image description here

2
  • 1
    I messed up the boot order, so this was it!
    – dr0i
    Mar 12 '19 at 10:01
  • Also if you're using windows you need to check the Enable EFI.
    – eXa
    Oct 9 '20 at 5:31
2

if you have (as it seems to me to understand) installed virtualbox and created a vm in it, then you must configure it, network and storage, if your vm is brand new.

If you get no bootable medium, it means that in your vm both the HDU and the CDU are empty (it can mean too that your vm HDU hasn't any boot record or any OS on).

Cheers,

Silvia

2

When you're first creating the Virtual Machine, be sure to choose Linux as the type and Ubuntu as the version.

enter image description here

I chose Windows by accident and it was giving me that error.

1
1

Although I have accepted the answers above, I realize that from the point of view of a complete noob to linux and operating systems in general, the concept of images ,ISO files etc is still confusing. I remember it taking me a while even after reading them. Primarily because Ubuntu had been installed on my PC by a friend, and I had zero experience there.

So I will try to answer it as simply as possible, for anyone in my position :-

When you install VirtualBox, it does not automatically come with the ability to run all the listed operatings systems (as I used to think ). An external file called the ISO or system image file is needed.This is the "bootable medium " referenced above .It generally has the .iso file extension. This file can be found on the website of the OS you want, and must be downloaded. This file is also used if you actually want to install the particular OS on your PC/laptop.

You can read more about them here

Now you must include/select this file as the virtual hard disk/ medium file as shown in the answers above.

2
  • 1
    “Although I have accepted the answers above” You haven’t accepted any answer yet… “it does not automatically come with the ability to run all the listed operatings systems” Technically, it is able to run all the listed operating systems but you need to plug in the particular operating system (usually distributed as an ISO file). “This file is also used if you actually want to install the particular OS on your PC/laptop.” Exactly. VirtualBox provides a virtual machine behaving like the physical one.
    – Melebius
    Sep 29 '20 at 11:21
  • +1; But you are usually connecting the iso file to the 'Optical Drive' (emulating a DVD disk) in the VirtualBox settings for 'Storage'.
    – sudodus
    Sep 29 '20 at 13:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.