Having rather serious issues with LibreOffice (v4.1.3.2) at the moment. This seems to have happened ever since upgrading from 13.04 to 13.10 - for whatever reason, a variety of different things are causing it to crash out.

The two main triggers that cause a crash are:

  • Opening a file of the same type as initially started in (e.g. opening a .odt file if I've started in Writer mode, a .ods file in Calc or a .odp file in Impress). Cross extensions (e.g. starting in Calc, and opening a .odp to switch to Impress) are fine. Once one file is open, however, I can open as many as I like of any type on top of it.
  • Closing any LibreOffice window will cause all of them to crash (it will come up with a recovery dialog for any file that was open).

I've seen other causes too (even opening the Save As dialog has done it a couple of times) but these are not as consistent. I don't get any kind of error report dialog like I normally would; I think it must have auto-checked "don't show me these" at some point so I'm not getting the error dumps any more.

I have no idea what's causing this, but I'd very much like to fix it if possible. I've tried fully reinstalling LibreOffice (sudo apt-get purge libreoffice*, followed by sudo apt-get install libreoffice), but to no avail - it continues to crash without fail whenever I perform one of the triggers above (not exactly uncommon actions). Any help would be much appreciated.

EDIT: I have also tried running from a terminal, using libreoffice --writer etc., but get no additional outputs or error messages that would help. I only know that it's crashing on close because it opens the recovery manager the next time I start it (even if there was only a single, blank document open, it will do this on close)

EDIT #2: I am still completely stuck with this. I have tried the command listed in Reinstall package and its installed dependencies to reinstall all of the dependencies, as well as purging entirely and installing from the PPA, all to no avail. The only difference now is that, with the version from the PPA, Libreoffice now crashes before it even loads a blank document, rather than when trying to open a file.

closed as off-topic by don.joey, Jez W, Eric Carvalho, Eliah Kagan, Maythux Mar 7 '14 at 4:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – don.joey, Eric Carvalho, Eliah Kagan, Maythux
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This is off-topic as it is a bug report. – don.joey Jan 31 '14 at 15:32
  • @don.joey ...Is it? I saw it more as a case of "does anyone know of this issue/how to fix it", hence posting here. Doesn't necessarily require dev intervention. – Jez W Jan 31 '14 at 15:38
  • Have you tried moving the config files in your home directory - ~/.config/libreoffice etc - those would not of been purged. – Wilf Jan 31 '14 at 15:44
  • @wilf Thanks for the suggestion - I tried moving ~/.config/libreoffice/4 to ~/.config/libreoffice/4.old after another purge/reinstall - it regenerated the 4 folder and crashed again when I tried to open a text document. – Jez W Jan 31 '14 at 15:47
  • Run it in terminal with libreoffice --writer, and open the document. Try other documents as well. – Wilf Jan 31 '14 at 17:00

You could try to upgrade to

First, completely uninstall your LibreOffice :

sudo apt-get remove --purge libreoffice
sudo apt-get -y autoremove 
sudo apt-get autoclean

Then remove the files that have been left :

sudo rm -r $HOME/.config/libreoffice
sudo rm -r /usr/share/libreoffice

Install 4.1.4 through PPA (4.2 if 13.10 or 12.04) :

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice

I don't have any issues on 13.10 (32 bits + Unity)

  • Thanks for the suggestion. I tried it, though, and it didn't work unfortunately... I am still getting the same crashes as before. – Jez W Feb 4 '14 at 9:33
  • I edited my answer, with now a way to completely remove libreoffice, then reinstall. – MrVaykadji Feb 4 '14 at 17:27
  • Tried purging as suggested - still no good. This new version doesn't even get as far as opening the blank document before segfaulting (according to the apport window that popped up) and quitting out. – Jez W Feb 5 '14 at 12:46
  • Really strange. It works ok for me. Maybe some java incompatibility? Have you some java installed? Another suggestion: try to make another user and test LO from there. – Rmano Feb 5 '14 at 17:23
  • @Rmano Not beyond the ones installed as dependencies for Libreoffice, no - I tend to stay as far away from Java as much as possible considering the constant zero-day exploits it was getting not too long back. New user account looked promising to start (presumably while it was making user files), but crashed in the same way. I'm starting to suspect that the somehow-botched upgrade to 13.10 (askubuntu.com/questions/407414/…) broke a couple of things slightly deeper than expected... – Jez W Feb 6 '14 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.