I've installed 29/01/2014 Ubuntu Touch on my Nexus 4 (with .84 radio from Android 4.3). I can make/receive calls and connect to wifi but when I turn wifi off I see a 3G icon flash up two or three times in the top bar but then just the "no connection" icon. There is definitely no data connection. I understood that this should be working without any user intervention. My imei shows up in "about", mobile data is set to "on" and my carrier is correctly identified as "O2 UK".

Can anyone please point me in the right direction?

BTW I already tried creating a mobile data connection in desktop and then copying to "/etc/NetworkManager/system-connections" and bringing up with "nmcli con up id" etc but I got the error that the connection was not supported by oFono.


  • Thanks for this post. I was having problems connecting my Nexus4 to Pennytel (in Australia). Just one point for clarification, on my version of Ubuntu Touch (14.04 (r229), the activate command is "activate-context". I am now able to surf with 3g data.
    – user257768
    Mar 13, 2014 at 7:54
  • Having the same problem with a data SIM from Vodafone Italy, but not with H3G Italy. Does anyone knows the root cause of the problem? Why some operators require to configure the context manually?
    – sergico
    May 15, 2014 at 16:14

2 Answers 2


I got myself connected by using the following ofono script commands in adb shell, first issue "cd /usr/share/ofono/scripts/" "activate-connection" "create-internet-context payandgo" (payandgo being my APN)

Still not sure why this worked as the default context did not contain any other details relating to O2 - for example, the password - but it did give me working 3G data.

For anyone else reading this, the command "set-context-property {context} {property} {value}" allows you to set any of the parameters contained in the given context (connection). For example, "set-context-property 0 Password payandgo" will set Password to "payandgo" in the default context. Also, the command "list-contexts" will show you the content of the context. If, while editing, it says the context is in use just issue "deactivate-context", make your changes, then "activate-context". HTH


Just providing more info on fishears' answer:

  1. Connect Nexus 4 to Ubuntu PC through usb

  2. Ctl+Alt+T (open terminal in Ubuntu PC)

  3. Type adb shell (given you have added ppa:phablet-team/tools and installed the android-tools-adb package)

  4. Type cd /usr/share/ofono/scripts/

  5. Type ./deactivate-context

  6. Type ./create-internet-context [your APN]**

  7. Type ./set-context-property 0 Name [your APN name]**

  8. Type ./list-contexts to see all parameters of the context you created in step 6. According to your APN you may need to set more parameters contained in the given context (e.g. password). Use set-context-property {context} {property} {value} to set all parameters necessary from your APN.

  9. Type ./activate-context

** Look them on Android under settings -> Mobile Networks -> Access Point Names (APN)

  • Can anyone confirm if the steps above helped resolve the mobile data issue? I have an E5 and my mobile data goes up and down something silly. I can be standing in one area and have no mobile data. I then turn flight mode on and off and then in the same area, I have full signal. I really want to try and resolve this issue as it is a real pain.
    – Phil UK
    Jul 15, 2016 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.