Libreoffice keeps on crashing randomly. It will do this when I am typing and when I am switching desktops or anything. There is no patter to it. I need some help here. Anyone had this problem or problem similar to it? Anyone have found a fix. Also it seems to happen especially prominently after my screensaver has started. I would say it happens about 97% of the time after that. This is an annoying bug and is keeping my productivity low.

  • I uninstalled and reinstalled and that didn't work. I also deleted the folder and that didn't work. – Sam Mercier May 15 '11 at 21:27
  • I get the same behaviour, was hoping to find a solution in this thread. It sometimes happens even when the LO window is not in focus. Out of curiosity, do you have lo-menubar installed? – geoffrey Jun 3 '11 at 12:19
  • You mentioned this happening after the screensaver has started ... I seem to get this after a suspend/resume – geoffrey Jun 4 '11 at 19:44
  • 1
    I have filed a bug bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/796206 – geoffrey Jun 12 '11 at 13:17
  • 6
    You accepted AJ00200 answer, can you comment which of the points he mentioned solved your issues? – Oxwivi Jun 19 '11 at 11:52

I had the same problem, but it was solved after an Ubuntu reinstall. However, most people would use this as a last option. Some things that you could to to replicate the results would be to:

  • Delete the .libreoffice folder as scouser73 said
  • Remove and reinstall Java or OpenJDK
  • Reinstall LibreOffice (try using the latest version from the website)

Hopefully one of those will help. If you do decide to reinstall, remember to backup all files you may need.


According to this thread http://ubuntuforums.org/showthread.php?t=1813246 and http://forums.linuxmint.com/viewtopic.php?f=47&t=77851&p=456737 this problem is linked with the graphics card in use is Intel HD Graphics and on an Intel Sandy Bridge CPU like the (Intel(R) Core(TM) i5-2540M).

The suggested fix is to disable anti-aliasing on LibreOffice. To do so go to the Tools menu, select options. Then on the next screen select "view" from the "LibreOffice" menu and then deselect "Use Anti-Aliasing"

I confirm it worked for me. So far Libre office has not misbehaved after I disabled the Graphics Output options from the LibreOffice View preferences. Thank's to the mint and Ubuntu forums. That saved my day. I've been searching for so long...


Since it is a Java error try to switch the JRE. Use OpenJDK. If you dont have OpenJDK install it.

In Libre Office go to ToolsOptions ... → LibreOfficeJava ( wait a little bit until the list of JREs appears) and then switch to version 1.6.0_20. When you highlight it, the location should be something like /usr/lib/jvm/java-6-openjdk/jre.

Hit the OK-Button and close all open documents or windows of LibreOffice. Then start Libre Office again.

  • Another option would be to entirely uncheck "Use Java runtime" box. – jnv Jun 15 '11 at 18:17
  • 1
    Now I can comment :-) But he should be aware that some functionalities of Libre/Open-Office need a JRE see here wiki.services.openoffice.org/wiki/Java_and_OpenOffice.org – AlexTheBird Jun 15 '11 at 18:29
  • Good point. That's true for most extensions, including Zotero which Geoffrey uses. – jnv Jun 15 '11 at 18:38
  • 1
    Thanks Alex and jnv. This sounds interesting. I managed to reproduce the bug once with the sun jre and with a document containing zotero references. But so far no crash with the opedjdk jre. I'll keep the openjdk one for a little longer just to make sure there are no further crashes. – geoffrey Jun 16 '11 at 13:13
  • I am still not sure whether sun java was the problem, but have not had the same crashes with LO lately, after switching to openjdk (but there was an LO update in the meantime, so who knows). Anyway, this was the most helpful answer for me (and got there shortly before jnv's also helpful answer), so +150 for AlexTheBird. Thanks! – geoffrey Jun 19 '11 at 9:13

I would suggest that you delete the LibreOffice profile, I think this may remove the problem you are having with random crashing.

1 - Go to your home folder

2 - Press CTRL & H to show the hidden folders

3 - Locate the folder .libreoffice

4 - Right click on it and delete it

This won't delete any documents you have made, basically what you're doing is starting from a clean slate.

  • Ok. That sounds promising. I'll try that soon. Thank you. – Sam Mercier May 9 '11 at 0:43
  • No that didn't help. – Sam Mercier May 15 '11 at 18:53
  • Since LO 3.5 the profile directory is ~/.config/libreoffice. Removing it stopped LO crashing for me. – Frank Zalkow Nov 12 '15 at 9:55

Every time libreoffice crashes, it leaves a log file either at your home folder and at the working directory. Read that log to find out the actual source of problem. Even I do suffer the same problem. Most of the times, the log says the JRE has something to do with it's crash. As a non-developer, I do not understand :-( I find removing the option to use unstable-experimental features (its in tools>options) helped a little.

  • I don't have 'unstable-experimental' enabled in the options, so this is not causing the crashes I am getting. Thanks for pointing to the error log files, I've filed a bug report on Launchpad. – geoffrey Jun 12 '11 at 13:16

I solved this faster and I did not want to start with the long run first :D

Just open LO. Go to settings and change which dialogues LO uses to save documents.

So change this setting to: "use LibreOffice dialogues to save documents"

(Option under "General")

Close and reopen LO and this worked for me.

(I found out that my LO even crashed while saving docs even without any JAVA version activated in LO.)


Edit: I've missed that Geoffrey is already using Sun JRE and so far it seems that OpenJDK may fix this problem. However the same crash was reported for OpenJDK.

It seems that the same problem was already reported for 10.10 without gaining any attention.

Assuming that Java is the source of the problem and you use the default JRE (OpenJDK), you could try Sun JRE instead of OpenJDK.

Sun JRE is in Partner Repository, make sure you have this repo enabled.


sudo apt-get update
sudo apt-get install sun-java6-jre

You'll have two JREs. You can either remove OpenJDK:

sudo apt-get remove default-jre default-jre-headless openjdk-6-jre openjdk-6-jre-headless icedtea6-plugin

(I am not sure what the default packages are, it's possible that you may not have some of these installed - apt-get will just ignore them)

or reconfigure default JRE:

sudo update-alternatives --config java

(select /usr/lib/jvm/java-6-sun/jre/bin/java )

In second case, to be sure that LibreOffice uses Sun JRE, follow Alex's answer, just select the one by Sun Microsystems.

  • Thanks for that. I am getting confused ... My bug report was for a crash using sun java, right? But the other guy who reported a bug said he was using openjdk. Looking through the crash reports I have in my home folder, some are for openjdk, some for sun java. (I have been switching between the two over the last few days trying to solve another problem.) So both are at fault? – geoffrey Jun 16 '11 at 13:33
  • Ah, I see, actually I thought you were using OpenJDK since you have reported the bug for openjdk-6. However, the bug I've linked seems to be really with OpenJDK, so in the end JRE may not matter. – jnv Jun 16 '11 at 15:51

I fixed my LibreOffice by reinstalling it. Ubuntu was using an unstable version of Libre and that was what probably caused it.

  • Which version of LibreOffice are you using now? – AlexTheBird Jun 17 '11 at 17:08

protected by Community Jun 11 '12 at 8:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.