After installing the Fglrx drivers from the Lubuntu software center, my computer stopped working. Actually only after I rebooted.

I have a 1080p monitor and it says "please set 1920*1080@60Hz as resolution". Pressing ctrl+alt+f1 doesn't work. I would like to unistall them from the live cd because I don't want to format the PC!

Can anyone help me?

  • Have You tried installing fglrx on live CD and aticonfig -initial, then copy good new xorg.conf to HDD's Ubuntu? I'm not sure about next solution, but You can boot live CD and work on HDD's Ubuntu (be careful) by few commands: askubuntu.com/questions/88384/… . – Esamo Jan 30 '14 at 20:49
  • Thanks to everyone for your help! I solved it! anyway I wasn't even able to boot into recover mode so I had to actually do it blindly! – Szmoro Jan 30 '14 at 21:51

Your monitor is saying that it can't display the resolution, not your PC, so your pc is probably still operating, but you aren't able to see what's happening. If your pc is responsive, this should solve the problem(you will just have to do it blindly):
Press <Ctrl>+<Alt>+<F1>
type in your username, <Enter>
type in your password, <Enter>
sudo apt-get purge fglrx*, <Enter>
type in your password, <Enter>
sudo reboot, <Enter>

It will remove the fglrx driver, and install the open source driver. Since you won't be able to see your progress after entering any of the commands, you should probably wait a bit after executing each command.


use grub and boot in (recovery mode) https://askubuntu.com/a/117954/216166

follow instructions:

amdconfig --initial -f; reboot;

if this still not helped try this:

apt-get purge fglrx*; mv /etc/X11/xorg.conf /etc/X11/amd.xorg.conf; reboot;

post this information by editing your question

lubuntu version?

lsb_release -a

graphic card?

lspci -nnk | grep -i VGA -A2 

its possible that the kernel/xorg version is not compatible with the fglrx driver.




Try booting into recovery or boot from cd and delete /etc/X11/xorg.conf, it helps sometimes.

  • I found the X11 folder, but there's no "xorg.conf" file in there! – Szmoro Jan 30 '14 at 20:38
  • Answers such as "try this" should be posted as a comment as they are uncertain until proven. So please, consider doing so, thanks. – slowbanned Jan 30 '14 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.