3

I am remotely logging into an Ubuntu machine through SSH(MobaXterm) using Gnome desktop remote environment from my Windows PC. I am having trouble with one of our video applications in displaying video.

Later I tried VLC as well. I could see a local file playing, but the vlc display screen is all black and there is no video.

I tried several things suggested for problems similar to this, but nothing worked.

Things I have tried:

export DISPLAY=:0 in bashrc 

I observed that with this change the Video applications and VLC if instantiated from terminal from SSH session, the application windows are opening on the actual remote ubuntu machine. Hence I reverted this.

Added the following code to ~/.profile (suggested here):

case $DISPLAY:$XAUTHORITY in
  :*:?*)
    # DISPLAY is set and points to a local display, and XAUTHORITY is
    # set, so merge the contents of `$XAUTHORITY` into ~/.Xauthority.
    XAUTHORITY=~/.Xauthority xauth merge "$XAUTHORITY";;
esac

added the following line to /etc/ssh/sshd_config :

X11UseLocalHost yes

But none of these worked. Can someone help me on this one?

  • Can anyone help me on this. I am really stuck with this display problem – Karthika Jan 31 '14 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.