I was trying to fix the boot loader because it was showing the processes as I shut down my laptop as well as fix the problem of the Ubuntu logo with the loading dots because it was off center and usually in a very small font size. So I followed these steps on a post on OMG Ubuntu and now things are completely screwed up.

Not only is it still doing the same thing on shut down but it switched my entire settings in Unity.

So what I'm asking is how do I restore things back to before I installed the "fix?"

4 Answers 4


Para los ususarios de Ubuntu 12.04 si instalaron sus drivers privativos Nvidia y al iniciar Ubuntu no les aparaece el logo en el arranque (la animacionde inicio de arranque con el logo de Ubuntu), entonces puede visitar esta página a ver si les funciona:


Yo estoy tratando de restaurar como estaba al principio, luego comentaré a ver si me solucionó el problema con el Plymouth-Manager (antes llamado boot-manager).

  • 1
    Welcome to Ask Ubuntu! This is an English-only site. Please post in English.
    – gertvdijk
    Feb 6, 2013 at 20:28
  • Sorry, Is not worked..! Feb 6, 2013 at 20:32
  • 1
    Welcome to Ask Ubuntu! Please translate your answer in English (You may take help of Google Translate). Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Aditya
    Feb 6, 2013 at 20:43

If you want to revert what that script did, do:

  1. Open a gnome-terminal (press Alt + F2 and type gnome-terminal).

  2. Open the GRUB default configuration file (you will get asked for your password):

    gksu gedit /etc/default/grub
  3. Replace the GRUB_CMDLINE_LINUX_DEFAULT=... line with

  4. Replace the line starting with GRUB_GFXMODE=... with


    Save and close.

  5. Open the initramfs modules file:

    gksu gedit /etc/initramfs-tools/modules
  6. Delete the line starting with uvesafb mode_option=. save and exit.

  7. Remove the splash configuration file:

    sudo rm /etc/initramfs-tools/conf.d/splash
  8. Run sudo update-grub

  9. Run sudo update-initramfs -c -k all

  10. Reboot.

This should restore the old state.

  • For step 3. The file is opening up as read only. Don't know why it's doing that. As for step 2. if my laptop monitor's resolution is 13668x768 should I change it to that or what you posted? May 8, 2011 at 18:57
  • I edited more detail into my answer. As for the resolution - that line is commented out, so it doesn't matter what you put there.
    – htorque
    May 8, 2011 at 19:16
  • Thanks for everything. Things are back to normal now. Much appreciated. May 8, 2011 at 20:29
  • Glad it worked! :)
    – htorque
    May 8, 2011 at 21:03


Rather than fixing Plymouth, I believe this just uses framebuffer during boot with a user-chosen resolution. It will give you more than text during boot, at least.


try opening up your synaptic package manager and reinstall "plymouth-theme-ubuntu-logo" this worked for me back when i was using 10.04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .