1

In Ubuntu 13.04 and 13.10 by default when you click on a .wav file, Ubuntu opens the totem video app and plays the .wav file completely garbled. This is a known bug that has been outstanding for quite a while.

What is a good work around?

I'm thinking of a lightweight player to play the .wav files without fuss and which can be set as the default for .wav files. If there is a simple way to make totem work that would probably be even better.

I get voicemails as .wav files and am looking for an easy solution for playing them.

closed as off-topic by Braiam, Radu Rădeanu, Richard, psusi, Avinash Raj Apr 10 '14 at 15:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Radu Rădeanu, Richard, psusi, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    What about using vlc? – jobin Jan 30 '14 at 5:49
  • Gstreamer is being depreciated. Please try 14.04 instead. – Braiam Apr 10 '14 at 1:06
8

Simply installing any other Audio player should work fine for you. I'd recommend Audacious since it is extremely light on resources and can play nearly every audio codec in existence.

You can install it by clicking the button below or running this command:

sudo apt-get install audacious

Install via the software center

Once installed you can go into your computer details via the dash and click on default applications.

  • turns out I already had vlc installed for other reasons on my system and though I think of it as not lightweight (not sure why) when I actually set it to play by default for wav files it pops right up. so that solution worked for me. Sounds like Audacious would also work well. – snowguy Jan 31 '14 at 9:26
  • 1
    Default applications won't work for wav files. I used the properties->set as default method. – snowguy Feb 2 '14 at 0:01
  • Really? That is interesting... I set mine through Ubuntu Tweak I believe. Either way that is good to know! :) – Weylin Schreck Feb 2 '14 at 0:16
  • Audacious rocks as a solution on Linux. Beside having the least complicated, and most WinAmp-like interface, it's easy to install (though you may have to resort to pavucontrol to sort out pulseaudio problems, see askubuntu.com/questions/338382/…). – Russ Bateman May 15 '14 at 13:05
-1

As mentioned in Ubuntu's RestrictedFormats, install restricted extras using below command to unlock codecs.

sudo apt-get install ubuntu-restricted-extras

Else, you may use an alternate player (a well known player which can support almost a high number of codecs) such as VideoLAN (VLC).

  • You can download it via Ubuntu Software Center
  • or you be use below command to install via terminal

sudo apt-get update

sudo apt-get install vlc browser-plugin-vlc

EDIT: Ubuntu's restricted extras will not install all needed codecs though there are few that will need a manual install/set-up such as PlayingDVD, Blu-Ray/HD-DVD.. etc. In that case, I'd recommend referring the restricted format as I've linked at the beginning. And to those who would like VLC, refer to the above mentioned points for installation.

Source: VideoLAN

  • tried installing ubuntu-restricted-extras. unfortunately, that didn't solve the bug with videos. – snowguy Jan 31 '14 at 9:05
  • As I guessed, there will be some manual workaround involved to allow HD-DVDs, BluRay.. etc codes. I've added it accordingly. – AzkerM Jan 31 '14 at 13:10
  • what evidence do you have that my problem has something to do with installing ubuntu-restricted-extras? i tried that solution and it didn't work. can you remove that so as not to lead others astray who are facing this known bug? Or am I misunderstanding what you are saying? – snowguy Jan 31 '14 at 15:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.