2

When restarting the Keystone service, it starts with a PID but within a fraction of second it stops. Checking the status immediately afterwards, it shows a different PID and when rechecking afterwards, it's dead.

root@hyper5:~# service keystone restart  
stop: Unknown instance:  
keystone start/running, process 37746  
root@hyper5:~# service keystone status  
keystone start/running, process 37750  
root@hyper5:~# service keystone status  
keystone stop/waiting  
2
  • (1) Which version? Grizzly? Havana? (2) Which OS are you running on?
    – K7AAY
    Jan 30, 2014 at 4:24
  • Can you post the contents of keystone's log file to pastebin.ubuntu.com and post the link to your question. You can find the log file from /etc/keystone/keystone.conf.
    – jobin
    Jan 30, 2014 at 6:00

3 Answers 3

1

I had this issue. All I did is removing 'persistence' from "driver = keystone.token.persistence.backends.sql.Token" and keeping "driver = keystone.token.backends.sql.Token" . After this perform service keystone restart. This enabled both ports 5000 and 35357 start listening.

0

This is due to keystone is not getting started properly and therefore port 35357 is not in listening mode. This seems to be anomalous behavior of service keystone. I am mentioning steps which have worked on my system for havana installtion on Ubuntu 12.04 Kernel version 3.2.0-67-generic. After a day of headache around this issue. Try these steps, preferably in the same order.

1) Remove keystone package:-

  apt-get remove  keystone 

2) Reboot your system

 reboot 

3) After reboot again INSTALL KEYSTONE.

apt-get install keystone

4) Check status of keystone service

 service keystone status

It will show start/running

5) Now do the necessary changes you want to do in /etc/keystone/keystone.conf

after making changes in conf file DO NOT RESTART KEYSTONE SERVICE

Use stop and start command to make an effect of restart but don't restart.

service keystone stop

service keystone start

For further help, pasting a dump of my CLI :-

http://pastebin.com/sduuFCL7

0

OK the only thing that worked for me is commenting "driver = keystone.token.persistence.backends.sql.Token" of the [token] section in the /etc/keystone/keystone.conf file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.