2

I had Windows 7 (64-bit) and Ubuntu 13.10 (32-bit) installed on my laptop ASUS N53S. Unfortunately, a blue screen appeared on Windows each startup, but Ubuntu continued to run.

I decided to remove Windows 7 in order to install windows 8.1 (64-bit). It was a good reason to upgrade :-)

I formatted my Windows 7 partition.

I changed from MBR to GPT with gdisk in order to be able to install Windows 8.1. and I succeeded in installing Windows 8.1.

When I start my computer, GRUB appears but Windows 8.1 doesn't appear, I can only run Ubuntu.

root@Clenet:/home/clenet# parted -l
Model: ATA ST9750420AS (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name                          Flags
 1      17,4kB  1049kB  1031kB               BIOS boot partition           bios_grub
 3      26,8GB  27,2GB  315MB   ntfs         Basic data partition          hidden, diag
 4      27,2GB  27,3GB  105MB   fat32        EFI system partition          boot
 5      27,3GB  27,4GB  134MB                Microsoft reserved partition  msftres
 6      27,4GB  299GB   272GB   ntfs         Basic data partition          msftdata
 7      327GB   721GB   394GB                Microsoft basic data          msftdata
 8      721GB   742GB   20,3GB  ext4         Linux filesystem
 9      742GB   750GB   8487MB  ext4         Linux filesystem

Ubuntu is installed on partition number 8, windows 8.1 on 6 (it created the 3,4 and 5 during the installation)

I tried boot-repair and I got some error messages.

  • EFI detected. Please check the options
  • EFI detected. Please use Boot-Repair-Disk-64-bit (www.sourceforge.net/p/boot-repair-cd) which contains an EFI-compatible version of this software.

Then I tried is boot-repair-disk (64-bit) on a pendrive, but it can't repair the boot. Here is the error message:

You have installed on sda8 a Linux version which is not EFI-compatible. It is probably incompatible with your computer. Please install an EFI-compatible system. For example, Linux-Secure-Remix-64bit and Ubuntu-64bit are EFI-compatible systems

Command os-prober gives nothing:

root@Clenet:/home/clenet# os-prober
root@Clenet:/home/clenet# 

Here is the output of update-grub.

root@Clenet:/home/clenet# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.12.0-031200-generic
Found initrd image: /boot/initrd.img-3.12.0-031200-generic
Found linux image: /boot/vmlinuz-3.11.0-15-generic
Found initrd image: /boot/initrd.img-3.11.0-15-generic
Found linux image: /boot/vmlinuz-3.8.0-35-generic
Found initrd image: /boot/initrd.img-3.8.0-35-generic
Found linux image: /boot/vmlinuz-3.12.0-031200-generic
Found initrd image: /boot/initrd.img-3.12.0-031200-generic
Found linux image: /boot/vmlinuz-3.11.0-15-generic
Found initrd image: /boot/initrd.img-3.11.0-15-generic
Found linux image: /boot/vmlinuz-3.8.0-35-generic
Found initrd image: /boot/initrd.img-3.8.0-35-generic
Found memtest86+ image: /boot/memtest86+.bin
done
root@Clenet:/home/clenet# 
1

Have you tried updating grub from Ubuntu? It should detect all the OS's in the disks:

sudo update-grub
  • Darent, I have already tried this command. I edit my post,then you can see the result. – xibi Jan 29 '14 at 23:40
1

You can try running Boot Repair! I had issues with Windows 7 and Boot Repair fixed all my problems, it is a program that you can install with a live cd and has a very easy to use GUI. To use Boot Repair first boot to the ubuntu live cd and choose "Try Ubuntu". Then run these commands in a terminal:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)
boot-repair

Those commands should add the ppa, install boot-repair, and run boot-repair. Then just click Recommended repair. If that doesn't work you can also create a boot info summary with the tool and it will write it to a paste.ubuntu.com address. Paste that link here if you have any troubles and perhaps that info can help us solve your problem.

  • I have also tried this like I said: "Other thing I tried is boot-repair-disk (64bits) on a pendrive but it can't repair the boot." I edit my post with the error message. – xibi Jan 30 '14 at 0:06
0

Here's the detailed manual on common problems with GRUB bootloader.

0

download this

http://sourceforge.net/projects/boot-repair-cd/

burn it to cd, and boot it up, it will fix any grub related problem in 2 minutes.

if that didn't work, as you indicated in your comment, then use this to boot into windows

http://www.supergrubdisk.org/super-grub2-disk/

once you're in windows, download easybcd on windows and fix it from there, that should do the trick.

  • I have tried it, can't remember the exact error message. I will try it again now. I will post the error message in my post. – xibi Jan 30 '14 at 0:10
  • @Baptiste i updated my answer – Lynob Jan 30 '14 at 0:18
  • this post might help too superuser.com/questions/627757/how-to-delete-the-bootloader/… – Lynob Jan 30 '14 at 0:20
  • Ok, I update my post (error message for boot-repair-disk). I'm going to try super Grub Disk2 Thanks for the answers. I will let you know – xibi Jan 30 '14 at 0:24
  • I can't install super grub2 disk to a pendrive? I use YUMI or startup Disk Creator bu both doesn't support the format of the iso. An idea? – xibi Jan 30 '14 at 0:43
0

Solution to my problem: Format the entire hard drive and install windows 8.1 next ubuntu 13.10. It's not a real solution but because of my backups, it's the best solution and the quicker after my 24hours trying to repair it.

Thanks for them who try to help me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.