My PC does have built-in graphic. I have vga switch and using it I would like to setup dual monitor. After pluging both monitors with VGA switch I had a duplicated view on both desktops. I would like to have extended view (mouse coursor goes between two desktops). Displays Settings does not show second monitor. How to setup it? How to make them two working in extended mode.

Before VGA switch I tried with DPI-DVI adapter, I was lucky to have extended mode on dual monitor but mouse cursor cannot go to second monitor - it was stick to the edge.

I've searched for solution to this problem many times. I've tried with xrandr, CCSM and many others, but nothing worked.

lspci | grep -E "VGA"

VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

  • 1
    You absolutely need a second video card to do that. – cochisebt Jan 29 '14 at 21:28
  • Doesn't VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) have any option to set up second monitor without video card? – marciano Jan 30 '14 at 17:53

If you mean you're splitting the output of one VGA connector on your PC, you can't - this (fairly obviously) just duplicates the signal to different monitors.

If you have a VGA connector and an HDMI or DVI connector, then you may be able to use dual monitors, depending on the graphics chipset. I don't recall ever seeing a motherboard with onboard graphics that had two video outputs, though.

  • Could you help me with my settings? lspci | grep -E "VGA" VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09). When I use dvi-dpi adapter to plug second monitor mouse cursor on second monitor is sticked to the edge. – marciano Jan 30 '14 at 10:50
  • Have you tried turning off the "Sticky edges" option in Display settings? (In 12.04 at least, click the top-right-hand 'system' menu, then displays .. the option is near the bottom ..) Even with that on the edges should only be a "little" sticky, though! – Steve Dee Jan 30 '14 at 11:02
  • Tried. Still mouse cursor is sticked to the edge. – marciano Jan 30 '14 at 11:23
  • Does the display settings dialog show your monitors the right way around? If the left and right are confused that might explain what you're seeing! – Steve Dee Jan 30 '14 at 22:54
  • Yes. It is OK. Monitors are not confused. – marciano Feb 3 '14 at 18:31

In theory it is possible, but you'll need additional hardware anyway and your graphics adapter should be able to handle the extra resolution. You'll need a splitter that is plugged to your video output and have two outputs for two monitors. Most of these, the cheap ones, will just split the same output between two displays BUT there are others more expensive that will send half of the horizontal resolution to each monitor. This one for example:


What they do, I think, is that the device pretends to be an ultra-wide monitor display itself with a resolution of say 3840x1080 pixels, so the computer thinks there is just one display of such resolution plugged in, but the device then sends the first 1920x1080 pixels to one of the displays, and the rest to the other.

If you are using a normal desktop computer, it may be better to purchase a second graphics adapter which have some extra advantages because this way you have more control about what you want to see in each display. But if you are using a laptop, a barebone, a Mac Mini, or some other computer in which you cannot plug an extra video card and you really need a second display, it is a reliable option.

Alternatively, depending on your needs an ultra-wide monitor with a native resolution of 3840x1080 or so could be a better solution. They're usually expensiver than two monitors that put the same resolution together, though.

Finally, you could also purchase an USB driven vga adapter, it is actually a graphic card but you can plug in into an USB port instead of having to mount it inside the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.