4

So I have a Lenovo u310 with Ubuntu 13.10 on it and whenever I try to disable my touchpad with the special button on my F6 key, it does nothing.

All the other special keys work, like plane mode and refresh page but only the touchpad button is not working.

What might be wrong with it?

  • What does xev -event keyboard have to say when you press the key? – Seth Feb 7 '14 at 2:48
  • It shows absolutly nothing. Every other key shows something but that one does not. – Kaspar Feb 7 '14 at 6:25
  • But it does show when I hold the Fn key pressed and press F6, then it works, but as just a F6 key. – Kaspar Feb 7 '14 at 6:26
  • Try just xev. Does anything show up then? – Seth Feb 7 '14 at 17:14
  • Still nothing. Seems to be the only F key that does nothing when you just press on it. But with Fn + F6 it works, ofcourse not in the way that I want. – Kaspar Feb 7 '14 at 18:18
8
+50

It does not work for me too(Ubuntu 13.10 Sony Vaio).

But I use following command(with shortcut key)

First determine the device id

xinput list

Then disable it, (this command as shortcut key action)

xinput set-prop 15 "Device Enabled" 0

Replace 15 with your device id.

SOURCE : https://help.ubuntu.com/community/SynapticsTouchpad

  • So you basicly make a shortcut key that executes that command? But how can you make it so that when you click the same button again, it will reverse it=? And are you using 13.10 ubuntu? Cause on that version the custom keyboard shortcuts options seems to be bugged. – Kaspar Feb 10 '14 at 23:20
  • Yh i m using, 13.10 GnomeUbuntu, and works nice for me. – Gaurav Gandhi Feb 18 '14 at 8:31
  • I m using 2 keys, 1 to enable and 2nd to disable it. – Gaurav Gandhi Feb 18 '14 at 8:32
  • With my x240 this disables the mouse buttons, too. – guettli Nov 11 '14 at 11:24
  • 1
    "xinput disable 15" also works (xinput 1.6.1) – personne3000 Mar 19 '16 at 10:26
1

This does not answer your question about non working key, but it will help in case you want to use another key instead.

  • Another way using Gnome Settings, Which I think it's better and simple as it will well integrated with desktop (Indicators...), the toggle script:

    if [ `gsettings get org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled` == "true" ]; then gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled false ; else gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true ; fi
    

    Query status:

    gsettings get org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled
    

    Disable:

    gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled false
    

    Enable:

    gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true
    
  • Using xinput:

    if [ `xinput list-props 12 | awk '/Device Enabled/ { print $4 }'` -eq 1 ]; then xinput set-prop 12 "Device Enabled" 0 ; else xinput set-prop 12 "Device Enabled" 1 ; fi
    

    12 is the id you got from xinput list, but there a drawback here using predefined id. For example, If a new USB mouse attached/unplugged before boot, touchpad could get deferent id. (It happens to me with USB mouse, my touch pad damaged)

  • Using xinput and device name instead of id:

    export touchpad_id=`xinput list | awk 'gsub(".*AlpsPS/2 ALPS DualPoint TouchPad[ \t]*id=*","") { print $1 }'` ; if [ `xinput list-props $touchpad_id | awk '/Device Enabled/ { print $4 }'` -eq 1 ]; then xinput set-prop $touchpad_id "Device Enabled" 0 ; else xinput set-prop $touchpad_id "Device Enabled" 1 ; fi
    

    My touchpad name is AlpsPS/2 ALPS DualPoint TouchPad got it from xinput list, replace it with your device name.

    Get device id by name AlpsPS/2 ALPS DualPoint TouchPad and store it in touchpad_id:

    export touchpad_id=`xinput list | awk 'gsub(".*AlpsPS/2 ALPS DualPoint TouchPad[ \t]*id=*","") { print $1 }'`
    

    Query status:

    xinput list-props $touchpad_id | awk '/Device Enabled/ { print $4 }'
    

    Disable:

    xinput set-prop $touchpad_id "Device Enabled" 0
    

    Enable:

    xinput set-prop $touchpad_id "Device Enabled" 1
    
0

Special touchpad key doesn't work on my Lenovo Ideapad 320 either (Ubuntu 16.04). I installed Touchpad Indicator and configured it to turn off touchpad automatically when mouse is plugged in. The app started doing its job after I changed switch method to Xinput in its settings.

-1

I think this site will answer your question. I do not own any lenovo to answer it SITE http://mydevelopedworld.wordpress.com/2013/11/30/how-to-configure-new-lenovo-x240-touchpad-on-ubuntu-13-10/

  • No, the OP is having problems with the function keys not the touchpad itself. Also, posting just a link as an answer is generally frowned upon. – Seth Feb 7 '14 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.